Garmin G1000 black screens on C172 & DA62

Hi, MSFS works fine and I normally fly with CRJ and PA28 Justflight.

Today, after a long time, I wanted to try the Cessna 172 with Garmin G1000 again and found both screens black.

To try to solve:

  • Community emptied
  • Uninstalled and reinstalled all Cessna 172 with Garmin G1000
  • Tested with “ready to fly” start on the runway.
    The above did not change the situation: always black G1000 screens.

The same occurs with the Diamond DA62.

Other aircraft on which other Garmins such as G3000 are installed on the Longitude do not have this problem.
It seems to only concern the G1000.

Did I miss something?
Thank you

Finally I found that if I turn the G1000 pfd brightness knob in developer mode >> ModelBehaviour is no action on the PFD related variable.
It seems the knob rotation dont produce any effect.

Solved:

Looking at MSFS folders I found in
C:\Users\xxxxx\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore
the two folders:
workingtitle-g1000
and
workingtitle-gx
both folders dated 10 of March

I can’t be sure I put them there by mistake but it seems strange to me; I have a link on the desktop pointing to the Community and I always open this to add the Mods.

However, with these two folders removed, the G1000 has reappeared.

1 Like

Did you try to install the GARMING1000 NXI on the marketplace?
It seems the latest G1000 NXI is the reason for the Black Screens?

Hi @laura830228 ,
the G1000 black screen problem is solved as per my previous post.
After that I onstalled the NXi and it works well with release 0.3.0; the previous release caused me MSFS crash.
Bye

Hello, i’ve got the same problem, but i don’t have those folders in Official, i do have them in Community so it might be another cause.

Congratulations for that,and at last I got my problem that not causing by the NXi addon ,but it 's the TCA Quadrant key mapping problem. I cleared all the key mappings to the Engine function on the A20N,than the G1000 black screen fixed.

I have no planes with G1000 in working condition, there are all dark, I have an empty Community folder, which I do after an update, first flight with a C208, nothing, second try with the C172 exactly the same. Hard to understand how every update manage to spoil something that was working before or is it possible that the sim got addicted to the WT mods? Which maybe are outdated after the update. This tell me that it will be a long time before the sim reaches stability, and it will be even longer before I buy a third party airplane, I consider scenery a waste of money, all you need is a runway to land.

Hi Laura,

I’m having same problem with my garmin 1000 screen blacking out on DA62 and Beachcraft G58. Did all I could but same problem persisted

If I disconnected the TCA throttle quadrant from the PC, the screens returns.

My question is: How do I clear the key bindings? And sort this problem?

Wouldn’t that affect the N20X?

Looking forward to hearing from you.

Mel

Today I had some flying time, busy with home repairs, and I removed all the planes mods that I use , C208, G36, DA62x, c152, TBM mod, etc.I also checked that I had the WT1000 nxi installed by the sim, I removed it, I like the regular WT 1000, so I left the other WTs 3000, 530, etc in the Community folder and the GTN 750 from pms50.com plus the JDs mod for the same. I load the G36 for a short fly and the Garmin Display worked very well with the PFD showing the GTN 750 mod. I made an ILS landing using the A/P in APRoach mode into KSTS and had a good landing. The plane performed well, no mod for this plane loaded. So it seems that may be an issue with outdated mods for all these planes in question. Both C172 worked equally well, I will try the rest some other day. The sim also performed beautifully as the scenery was excellent. When problems happens, be curious and try different approaches to solve the problem, and when you do, is very satisfiying.

Hi, if this can help here is how I solved same Garmin black screens:

Thanks you all for the contribution.

Have tried most of that but problem seems to be connected to my Thrustmaster TCA throttle quadrant.

If I connected the TCA quadrant, only DA62 and G58 screens back out, all other G1000 and 3000 equipped airplanes work fine.

And As soon as i disconnected the TCA USB connection from from the PC…boom, the screens comes alive.

Same problem even with my community folder completely out.

That doesn’t happen with other peripherals like Logitech X52 throttle quadrant. Works very well with that.

So wondering if I’m missing something with the AIRBUS thrustmaster TCA system.

Funny enough, all other airplanes screens works fine with the thrustmaster, including the C172 G1000.

Will keep playing with all mods and settings then see how it goes.

Fingers crossed.

1 Like

Just to add up, this happened just after Sim update 5. All worked fine before then.

Hi there ,All you need to do is clearing the INSTRUMENTS AND SYSTEMS key bindings with TCA.

4 Likes

Awesome Awesome Awesome.

Thank you so much. You’re a lifesaver.

I did just that and flew the DA62, G58 and C172 -G1000 and all displays stayed on.

Fly safe

1 Like

Hi there, it looks like I have the same problem. Could you explain to me which key bindings for tools and systems I need to clear? I didn’t understand a bit:)

Thank you guys

MODERATOR EDIT:
Hello

I have the concern of the Garmin that turns off, I disconnected the TCA the Garmin 1000 it is turned back on immediately.

Thank you for your help.

Jean-Paul

Bonjour

Hello I have the concern of the Garmin that turns off, I disconnected the TCA the Garmin 1000 it is turned back on immediately. Thank you for your help. Paul
thank you for your help

Jean-Paul

Hi all
after upgrading to SU VIII the garmin G1000 the double bouton to select Way point don’t work when you push to select and drop a way point .
also to select all functiuns …

Did you have the same issu
i use the DA62 & TBM …

or i miss something ?

Displays went dark but visible in Longitude after update. Went into ‘Aircraft Systems’/ ‘Lighting Config’ ‘Master’ on Garmin computer and turned up the lights. OKAY now.