Garmin G1000 FMS rotary in control

Hi everyone a Happy New year.
I am having problems trying to enter a flight plan using the G1000. The inner rotary control that is supposed to enable you to enter the start ant destination in the flight plan menue is not working. Can anyone give me any tips please.

Are you using a PC? If so hold the left mouse button on the centre knob and click the right mouse button. This should bring up a cursor so you can enter stuff in the field. The inner knob should then scroll through the characters and the outer knob moves to the next character.

Or simply use the „legacy“ mouse and don‘t have any problems.

Thanks for the information i will give it a go and let you know if I am successful

Your solution sadley does not work. I am on a PC windows 11. Flight model is set at Legacy. Highlightting the inner button ( the little one) it turns yellow for a second, using the mouse wheel nothing happens. Highlighting the inner wheel you can scroll through Destination, waypoints arrival etc. But am unable to get the letters to enter in the FP.

Flight model shouldn’t affect how the the mouse interacts. BTW…others may correct me but I think you should set flight model to Modern not Legacy. Thats whats its set to in mine.

As far as the mouse goes I think Ephedrin87 was referring to the cockpit interaction system being set to Legacy…not the flight model. Cockpit interaction can be found under Accessibility in the general options. In my sim there are 2 options…Lock or Legacy. I’ve got mine set to Lock and in this mode I interact with the FMS as I described in my first post. Not sure about Legacy as I’ve never tried it. Someone else may be able to describe it for you.

Don’t use Legacy flight model. That will cause your planes to be uncontrollable.

You want to set cockpit interaction to Legacy mode. That’s under Assistance menu. THose are 2 totally different things.

Thanks for the tip I will give it a try

Think there may be some room for confusion with the Legacy options, just to clarify, the Flight model should be set to Modern, but the controls set to Legacy (this option was introduced with SU 6 or 7).

I cannot locate the opinions of setting the controls to legacy in the controls menu. Or in the assistance menu…it is only available in the flight model. I am using a upto date PC running windows 11 with al the MSFs updates installed and have the garmin add on installed. I have also changed the mouse.

Go to General Options/Accessibility/Cockpit Interaction Systems

There you can set either Legacy or Lock. Legacy is the original system and Lock is the new one intrduced in SU7 (I think).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.