Glitchy Pixels at top of screen

Yes indeed TAA to DLAA does the trick, thank you.

1 Like

Works for me too

Switching to DLAA is workaround. Not a solution. I would like to devs to notice the problem and fix underlying cause rather ignoring that as “solved” problem.


Indeed. DLAA is clearly inferior to TAA and we shouldn’t have to resort to it


Anyone try the new Nvidia drivers? Unfortunately I’m out of town and can’t.

See this thread: Poll: Nvidia 497.09 Experience

Hello everyone,

We are carefully monitoring reports from our players that the latest Nvidia Geforce driver (497.09) may be causing issues with Microsoft Flight Simulator, including, but not necessarily limited to, crashing to desktop (CTD) and blue patches where ground terrain textures should appear. Please vote in this poll so we can better understand how widespread this issue is and if it is affecting everyone who has upgraded to the 497.09 driver or only a subset of players.

Please choose the appropriate option for your version of Windows (10 or 11) and which DirectX version you are using (11 or 12).


Oh no don’t tell me that. I just updated my drivers!!!

I updated the drivers, already saw blue patches on ground, but no CTD so far. I will report if tearing appear or not if I avoid CTD’s.

This happens sometimes to me but not always. I have to restart the sim to make it go away.
Makes it difficult to find what the issue is because the problem goes away by itself until it happens again.

I returned to the Nvidia 472.12 and no more CTD or glitchy pixels after few hours of flights.

I’m very tired about Nvidia bugged drivers since one year.

Hope this can help you !

PS : Nvidia move your *** with your drivers, we are not beta tester !!!


Thanks, i will try deleting the shader cache first and driver re-install.
If nothing works i will go back to old driver. :frowning:

You would think more people would have this problem with TAA being the default antialiasing?

Wish I had read your post earlier! Just updated my RTX2080Ti to NVidia 497.09 and now MSFS (DX11) is CTD I am now going to try and roll the driver back :angry:

after 497.09 testing, I didn’t see any tearing or glitchy pixels in ~20 flights. But it started to CTD so I did rollback to 496.76

I have just closed a similar thread (which may have some interesting information) and referred folks to this thread.

Still had this issue after deleting shader cache and clean install of driver 496.76.

Now i did a clean install of the sim.

Yes, basically downgrading to DLAA or lower to avoid the issue. That’s not really a solution for me. Fast sync does not work (tried all sync settings, mainly using G-SYNC). But hopefully it’s in drivers, as I didn’t experienced it with newest drivers (with TAA, behold!). Otherwise I don’t believe it will be fixed, as devs probably did not even noticed this problem.

This issue suddenly appeared for me today. Hadn’t seen it before, glad it’s not just me. :grinning:

I also returned to previous versions but unfortunetly Live Weather doesn´t work. Any ideas?

I can tell you, AMD is not better. Before I bought the RTX3090, I bought an RX6900 or what the hell it was… the biggest newest card they had.

I never got it running, in 13 days I tried 20 drivers from AMD absolutely none was working stable with the sim.

I‘m glad to be back to Nvidia, because they have at least some drivers for the sim which are working.

At the moment I’m running without any problem, for hours.

What I just noticed the my sim runs better without using MSI Afterburner.

vsync in game option does not force the activation of vsync.
it is an adaptive setting (half refresh monitor)
that’s the reason why you only have the option of 30 or 60 FPS lock.
You will get the same result if you set Vsync to adaptive ( half Refresh rate) in NVCP.
This seems to be the option that gives more smoothness but has the disadvantage that if rendered frames fall below the refresh rate, tearing appears.
I have tried to find a balance between smoothness and performance by setting Vsync off in game and enabling vsync in NVCP, fps locked in 35 and low latency mode in ultra.
it’s not as smooth as having vsync locked 30fps in game but at least the tearing doesn’t appear randomly.
I’ve tried vsync fast but I get stutters.
Hope Asobo will fix this issue ASAP.