GNS 530 Autopilot Failure after SU 14

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

2 tags are required: One for platform, and one for aircraft.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.


Which aircraft are you reporting an issue about? (Please also add the proper tag for it)


Which aircraft version are you experiencing this issue on? (You can find this listed in the Content Manager under the Aircraft Name)

dc-3 aeroplane heaven world travel

Brief description of the issue:

AP will not engage ROL or NAV. HDG selection result in plane turning north, ignores further heading adjustments. VS is ok.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Take off, at 500 ft, engage AP. No ROL function available. Then try NAV after getting on flightplan course, or HDG. VS and ALT work ok.

PC specs and/or peripheral set up if relevant:

Intel I9, 32 GB RAM, GTX 980 Ti 6 GB, Win 10

Build Version # when you first started experiencing this issue:

MSFS 2020

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

The failure with AP does NOT occur in the Cessna 172 with Garmin GNS. All AP functions are available. Problem must be a DC3 - Garmin incompatibility created after SU 14.

Last week Dev update:

mentionned that the DC-3 Enhanced was updated, maybe it introduced an issue with the GNS.

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

in the middle of the flight, the garmin autopilot is saying “NO GPS POSITION”, and I don’t know what to do, the autopilot may be still functional. I’m on xbox series x.(edit: THIS SOLVED IT BY ITSELF so I don’t really know)

If relevant, provide additional screenshots/video:

1 Like

Turn the battery off and on again.
I noticed it too. How long were your flights when this happened?

It’s not the aircraft, but the SU 14. You have to have a flight plan and fly long enough. You probably didn’t fly your Cessna long enough and/or your flight plan wasn’t long enough.

About 6h, thanks, I tested it lastly, and that worked, but 5h later, the black screen bug went on, but that’s another xbox bug, anyway, thanks for helping.

1 Like

I can confirm this still happens randomly, try pressing the cdi button to toggle to VLOC Mode, press cdi button again to toggle back to gps mode, NAV mode should be able to activate again and AP should behave like normal.

At least that worked for me.

Flew from NVVV to NVSC (about 100min /250nm) everything went normal, when continuing from NVSC after I unloaded some cargo and a stay of approx 30min (batteries off) I went to AGGB via SCRUZ and the bug appeared right after start when I tried to activate the AP in NAV mode, could solve the issue like I described above. Hope that helps.