Ground crew marshaller lost his baton / wand

It doesn’t seem like they fixed it in the next upcoming update. If I’m wrong, Someone correct me.

Nope you’re right, it’s still broken. But it’s far from being the biggest issue so it doesn’t bother me that they don’t prioritize this for now.

It’s indeed not the biggest one but it tells a thing or two how bugs are handled overall. This is one of the few bugs that got recognized in the forum and isn’t lost in Zendesk-country. This should be a rather trivial fix that won’t affect other parts of the game yet it’s surprising how long it’s been open already.

The issue arose when LODs were changes a few SU ago.

It looks like a LOD issue, but is probably a symptom of a much bigger issue with LODS, that to fix, may be considerable work.

If this is so, then think of the Missing Batton, as an indicator, of when and if LODs issue get addressed.

Funny enough, for me, the wands are both in the marshaller’s hand until I get closer.

Once it’s close enough for the marshaller to start waving, one of the wands just disappears.

I investigated a bit this issue, because I was curious to understand what was happening.

  1. Both batons are in the same 3D model, so we can say that this is not a LOD issue with the model or both would disappear, even if it looks like one. We can also say this because, when LOD makes a model appear/disappear, it quickly fades in/out, and here, the baton just suddenly disappears.
  2. Right Baton disappears no matter which animation is playing, so this is not an animation issue.
  3. It seems that it only occurs with some Marshaller models (Woman Summer model?), but I still need to try to trigger them all (this topic for example shows a Man Winter model and the Right Baton is present)

After playing with the Dev Mode a bit, it turns out that the Right Baton suddenly gets in the exact same position as the Left Baton:

Both battons are properly placed:

Moving the camera a bit makes the Right Baton to move at the same position as the Left Baton:



Why does it happen only when the camera gets closer? I’ve still no idea…
Does it help? Maybe not but I’m sure Asobo could fix this in a wink. :slight_smile:

7 Likes

Great diagnostic work – well done.

I feel like trying out this VDGS mod to replace the ground marshall and their missing baton.

Overview | MSFS Visual Docking Guidance System (nool.ee)

1 Like

I think I figured it out… you have to land at an airport that can afford for their crews to have two batons. :rofl: This was at Palm Springs.

(Yeah, one of the wands disappeared when I got closer - I just needed a little fun today.)

1 Like

Wait.
So what you are saying is that the Right baton is actually there…it just moves to the Left hand and that both batons are in the left hand?

SU5 was when it started

OK so in fact, the baton 3D model has both batons at the same place, coordinates 0,0,0. Then, in game, the left baton doesn’t move and the right baton moves to the right hand coordinates.

For a reason I still can’t explain, with all the Female 3D models, as soon as their LOD changes, the right baton goes back to the 0,0,0 coordinates, hence is perfectly merged with the left one.

There is no issue with any of the Male models so far, and that’s why some of us thought it was fixed.

I looked for two days why this behavior is happening ONLY with the female models but didn’t find the culprit so far.

Anyway, I’ve a fix incoming while waiting for Asobo to properly tackle the issue:


:partying_face:

That is great news, great work. :+1:

One less MSFS frustration that seems to be of no interest to the developer to even acknowledge, let alone fix.

These is a lot to be said for "If you want a job done right, do it yourself".

Thankfully t there are members of this Flight Sim Community that have the skills to figure theses thing out, and share their findings with the rest of us.

Mod is ready, enjoy!

3 Likes

Many thanks for this Mod.

I tried installing it, but all my Ground staff were not there – probably my error, I will try again…

But I believe the layout.json may need fixing, as it appears to be one from the original, and not one that only contains the layout of this particular Mod’s file ??

The Manifest.json package file size may also ideally need to be adjusted ?

Yes there is indeed something wrong, I’ll make a new archive, thanks for the info!

1 Like

I assume you have the automated layout.json generator program ?

Trying ti do it manually is very prone to error !!

OK it’s fixed, I don’t know what I did, I added the original files to the archive instead of mine… :face_with_head_bandage:

How soon before it updates on .to ??

1.1 seems to be totally mixed up with its folders ?

Re-d/l it. :slight_smile: