Ground snow overlay popping in and out with distance

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Both with and without

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes

Brief description of the issue:

Snow ground cover is removed when approaching the area, and pops in again as you move away. I’ve had this at airports and in other areas, particularly with weather themes. It is a LOD popping issue like the terrain tiles (and is probably related).

Provide Screenshot(s)/video(s) of the issue encountered:

https://youtu.be/WDvKKl0T0c0

ICAO or coordinates (DevMode > Debug > Display position)

In this video: LFTD, but I’ve seen it in many other places too.

Detailed steps to reproduce the issue encountered:

Set a weather theme with light snow, say 5cm depth. As you fly towards the area watch the snow disappear, and looking behind you, watch it appear as you fly away.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

It’s been a while, at least a few months.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: