GSYNC won´t work

LG 34gn850 monitor 144hz and 5600X / RTX3080, Win 11.

Gsync has never worked in this game and it works on every other game i have. NVCP is set correctly (i think), Gsync selected for Full screen and windowed mode. Even tried Nvidia profile inspector, no luck.

I check the gsync from monitors OSD, which shows current hz, it stays locked at 144hz.

I think the game would be better with gsync, image is not that smooth. FPS wise game runs fine 40-50 on airport and over 70 in the air. DX12 seems to be working just fine.

Any ideas would be appreciated!


Update: Gsync works if game is selected to view windowed, not fullscreen.

There are no settings in MSFS for G-sync, only in NVCP. MSFS doesn’t know or care if you are using G-sync. G-sync works from the GPU to the monitor. Make sure you have a recent DisplayPort cable between your monitor and GPU. Check your monitor’s manufacturer to see if they have a Windows driver for your monitor. The default Windows driver is basic driver not specific for any monitor.

I think it’s a bug in nVidia driver. It used to work a few months back, but I tried it recently and it didn’t. (I have it set to Fullscreen, didn’t try Windowed)

NVIDIA should have a fix for this.There isn’t anything MSFS/Asobo can do.

I did see an updated version of NVCP in the Microsoft Store. You might want to download this first.

Windows driver for monitor is installed and NVCP was updated 16.10.2022. Good advices though!
This seems Nvidia problem, allthough i have red other forums stating MSFS is not true fullscreen and that´s the reason gsync won´t work correctly sometimes.

I think we just have to wait for future updates from Nvidia. I just hate it for not being completely smooth as it should. Stutters are way down, good job Asobo and no crashes either.

“Update: Gsync works if game is selected to view windowed, not fullscreen.” Update on that one, it does fluctuate the hz, but it seems a bit inconsistend.

NVCP has a G-sync option to be enabled for either windowed or full screen apps. MSFS has always used a hack to run in a window BUT looks like full screen. This allows MSFS to use WDM to manage the screen. I had G-sync enabled for over two years without a problem that I know of. And have not had any screen tearing that non-Gsync monitors have.

You can force it on by using nvidia inspector.

It doesn´t work either. It shows that it is enabled or forced for MSFS.

Works fine here if I force it through inspector. There are two or three options you need to change in there in order for it to work