Hard Right Yaw on Takeoff

Aircraft yaws hard to right on liftoff then continues ‘crab’ flight. Auto rudder and takeoff assist are on. All piston engines (don’t fly jet). I normally fly the 172. I tried Rudder Trim, it takes several inputs, but then it returns to a Crab, about 10 degrees. I have to keep inputting left trim. There is no wind. I manage to land without bending the plane, but not straight on. Entering Center Rudder has no effect that I can see. Tried the Default ALPHA yoke profile and the programmed 172 profile. Also tried restarting the Sim.

What rudder pedals are you using ?

Rudder shouldn’t have an effect because as you say, you have told the sim to do the rudder input for you.

Given that you have those assists and as expected, your rudder input does nothing then the only other option is wind. Whether you think there is some or not.

Try this:

  1. Turn off the assists.
  2. Make sure you only have one rudder binding in all your devices.
  3. Go into the game at an airport
  4. Go into weather and make set the winds and turbulence to the minimums.

Now see what happens.

If it still happens then tune an ATIS channel on your radio and make sure ATIS is saying there are no winds and any windsocks are drooping straight down.

Thanks. All fixed. I had Auto Rudder on as well as other Rudder controls mapped on my Yoke. Maybe there was some conflict. I removed everything but Auto Rudder. I also made sure that Assisted Takeoff was on. I always had wind set to zero. All the birds now fly straight and true(more or less).

TECHY111 - No rudder pedals.


Add images

I’m using a Ch yoke and have Ch pedals as well. Have been trying all manner of settings with/without the use of pedals connected to yoke or to quad (but not both at the same time).

It seems the only way to keep the plane from veering off the runway during takeoff or landing is to:

Disconnect the pedals from USB port with settings in the quad
Remove any rudder mappings to the yoke
In Assistance - click auto rudder on, click landing assist on, click take off assist on then click on apply and save.

This is a Mickey Mouse way of flying but hey, if it keeps the planes on the runway it will have to do for now.

Try switching from FSX legacy in settings

Please mark as solved so others know to look here for a solution.

Done. Wasn’t aware of that. Thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.