Heading Increment Bug (10 degree instead of 1) Explained

Good morning everyone,

I have received word that this particular bug will not make it into Sim Update 3. It is in final testing and did not make it into the build, but is now scheduled for World Update 4 (late March). We know this bug is very important to many users and regret the delay, but thank you for understanding.


is this a joke? seriously how hard can it be to correct? it makes any sort of IFR flight completely useless

still the database for gps approaches is broken. i have already abandoned this game for xplane. it’s wild how poorly done so much of it is


Software development is not as easy as many people make it out to be, especially if you have a team of developers. There are lots of reasons why it would take longer than expected. In the meantime, you can use these helpful suggestions.

[RESOLVED] Heading (HDG) Bug - Archives / Bugs & Issues - Microsoft Flight Simulator Forums

HC Alpha 10deg Workaround - Google Drive

No, we don’t understand. This has been a problem for 6 months and it is unacceptable to not be on top of this, especially when you partner up with Honeycomb and you can’t even use half of the features of the devices because of this bug. I still have messed up takeoffs because I can’t use the dedicated gear lever on the Bravo throttle quadrant and have to pan around with the mouse and click on it.


and as its not “only” the honeycomb users being affected, this is getting ridiculous and utterly annoying indeed … :triumph:


Yes, very dissapointing.


Frustrating as it is, perhaps using the ‘G’ key on your keyboard would be easier in the mean time?

I also wonder what exactly the fix will include. I think there are two elements to this issue:

  • The always-on 10-degree jump for users of certain peripherals when switches are set in certain positions
  • The ‘runaway’ acceleration where clicking repeatedly on the heading bug knob with the mouse causes it to change from 1 degree increments to 10 degrees. This is a long-time ‘feature’ of the Microsoft series, which has its uses but can also be quite annoying. It applies to many knobs not just the heading bug.

I’m guessing only the first one is fixed but I’d love to see a better solution (or options) for the second.

Likewise :wink:

oh give me a break, typical patronizing response.

they can figure out how to model the entire earth with stunning accuracy but it takes them 7 months to fix the heading bug going in increments of 10 to increments of 1?

xplane has never had this problem. the honeycomb alpha and bravo work flawlessly on it. i regret my purchase. it looks gorgeous but anything you would want to work doesnt. gps, half of the buttons on premium planes, missing approaches, half the planes completely wrong performance, etc…


I agree in general, except in this case, it is a known bug for old timers since at least 2004:

Heading Increment Bug (10 degree instead of 1) Explained - #2 by CptLucky8

This tells there is a problem in their approach to “keeping what’s good from FSX” and “developing new implementations for what’s bad in FSX”. They have no clue whatsoever what are the shortcomings developing add-ons on FS8,FS9 and FSX, how the same shortcomings are perpetuated up to P3D5, how this is impairing 3rd party developer creativity and how in not listening to a larger population of long time 3rd party developers knowing these shortcomings, they are perpetuating the same bugs over into FS2020. I know some of these for a fact, I have to recode FS internals in memory to workaround some of the autopilot code to make the GTN and the GNS V2 working from FS9 to P3D5, all using the same code base unchanged whatsoever with the same coding mistakes. (I call this mistakes but some might find this just an ‘implementation detail’).

Please don’t read the above as a rant, it is not the point. The point is there is a visible side to the problems which might lead some thinking these can be resolved quickly, and there is another side knowing how these things are internally coded in the flight simulator code base which is important to factor in with these questions. Some of these issues are rooted more profoundly in ancient code than you’d think and this shows sometimes when you’re used to develop and recode the internals to make your add-on working, which is something no longer possible with the FS2020 for XBox sandboxing approach.

Wow, what a shock, they lied yet again about something. “Fixed” indeed.

I’m not being patronizing at all. I’m disagreeing with your statement and pointing out that software development can be difficult, especially with something as complex as a flight simulator. I also offered you some work arounds that solve the problem temporarily until it is fixed in the sim.

Thank you for explaining to me that software development can be difficult. I had no idea.


You can’t use the gear lever on the Bravo? Hmm, is it a particular aircraft issue? Note, I’ve been flying the Bonanza and use the Bravo gear lever all the time.

1 Like

Yeah that’s a new one, the gear lever on my Bravo works fine. Maybe it’s mapped to toggle instead of gear up and gear down?

1 Like

I don’t know if you have read the title of this topic but it’s about the problem with “always-on”-switches like the gear lever that causes excessive acceleration of the knobs and trim. If you have a way of using the gear lever without messing up these stuff please let me know how.

I only have the Alpha but I worked around the always on switches using free third party apps. There might be better workarounds but I have only tried this one:
Honeycomb Alfa and Bravo setup with FS2020 - YouTube

Oh, so you’re basically not using any of the switches on the Bravo then, not just the gear switch, I gotcha. I know there are ways around it using FSUIPC and LUA scripts, joystick gremlin, Axis and Ohs and other hassles like that but I’m tired of having to do stuff like that to get something simple working so I haven’t tried any of it yet and am just waiting for it to be fixed. I might give the FSUIPC and LUA script thing a shot though.

My CH yoke levers cause this also. So I am patiently waiting for an update so I can use them…please Asobo, fix this.

The Alpha has the same issue with always on switches. FSUIPC I think requires the paid version to use the re-mapping capability. In any case, the video I linked demonstrates both the Alpha and Bravo set up without causing the heading bug issue. However, it is a bit of a hassle as you’ve mentioned.