Help with slow performance on extremely high end PC...not sure what else to do

I’m looking at the i9 (for future) and an MSI board. 64GB of DRDR5 (I have DDR4).

Otherwise I can reuse everything else.

It seems to me you are going about things in completely the wrong direction, rather than lowering settings you should be trying to increase load on your gpu until you are free of mainthread limited. Once that is achieved you can then start with the fine tuning.

Be mindful of the cause and effect. Being limited by the mainthread is independent of GPU load and vice versa. If you’re severely limited by the mainthread to the point where decreasing LOD to only 50 finally gets you acceptable performance, there isn’t that much you can do to improve performance. That’s exactly why lowering resolution didn’t benefit OP at all - the bottleneck lies in the CPU, not the GPU. There’s not much OP can do to significantly increase performance except turn down terrain LOD.

Threadripper is great for multithreaded purposes, but severely suffers for lightly-threaded programs (like MSFS) due to its lower base clock frequency. Trying to push all that through a single core with a base clock of 3.7 Ghz is going to be a bottleneck.


Stick with TAA set graphics ultra and renderscale 200. Then start lowering terrain LOD until you are stable. A few extra fps can be had by lowering clouds to high and a little more stableness by lowering traffic settings.

Good luck.

1 Like

note: thats important, because that mean you speak about the SU10 BETA , and not the current “release”.

Have you already tried the DX12 setting instead DX11 ?

I have tried both DX11 and 12.

Also this has been as issue for a long time. Just now starting to try and fix it.

Well got new processor and new Mobo. Same issue really.

It is a bit better though but LOD has to be around 100 to get at least 30 FPS. LOD of 200 is around 19-20 FPS.

Guess that’s what I will have to stick with until Asobo optimizes for Multicore or something. It does always say “limited by Mainthread”.

a note: you can open the Taskmanager - CPU view and choose the “show core diagramm” , then you might see why these message is. Mostly one core is in full load :slight_smile:

What processor did you get? I’ve got the 5800x3d and it seems perfectly suited to msfs :ok_hand: disabling SMT was the biggest improvement I experienced.

I found slightly higher main thread limitations on dx11 Vs dx12 so sticking with DX 12 I’m running su10 beta which isn’t running great in its latest variant but still averaging 55-60 fps

I got the i9 12700 I think.

What is SMT? I turned off hyper threading and Virtualization in the bios.

Probably is but what is the fix is the question :slight_smile:

SMT is amds hyperthreading don’t matter if you have an Intel.

I recently tried a different approach which turned out very positive for me - perhaps it could for you too. I have a Ryzen 5900x cpu, Radeon RX6800 gpu, 32gig memory and a Samsung Qled 7 series TV/monitor which can do up to 120Hz.

After reading a lot of posts in this forum, I stopped chasing fps and set my refresh rate back to 60Hz in win 11 and set MSFS to 30 with vsync, DX11, and HD on. Set everything in MSFS to ultra and terrain LOD to 300. Freesync is the only option turned on at AMD driver level. Disabled multithreading in the bios helped a lot also.

Buttery smooth result with my fps mostly at 30 @ 4k resolution/rendering during flight but of course gets knocked down 2-5 fps while on the ground. I have the occasional studder flying but I do a lot of flying with the F18 doing close to mach 1 so a lot of ground is covered in a short time frame.

I’m feeling like I won the lottery!