Hide mouse pointer when not in use

Is there a way to hide that annoying mouse cursor in VR if you are not using it? I haven’t had a chance to look into the cfg file to see if there’s a ‘back door’ way to do this. If not, it shouldn’t be that difficult for the devs to hide it after non use.

My mouse cursor disappears if I don’t touch the mouse for about 5 seconds. The only time it doesn’t is if it is hovering over a switch with associated text showing the switch action. Make sure your mouse pointer is not sitting over any switches.

1 Like

I’ve tried just about everything to get it to disappear but no luck. Since you mentioned it, I will double check that it’s not hovering over something to see if that works and I just overlooked it.

Jeff

I have to click one of the buttons on my mouse to make the pointer appear in VR so maybe there’s a setting somewhere to allow this - not sure if it would be a windows setting, a windows Mixed Reality Setting, or a VR setting in FS2020. It might even depend on my muse hardware.

However, you are right - it is was there all the time it would be a big distractioin.

I spoke too soon :slight_smile: With a little research I found this nifty little free application called ‘auto hide mouse curser’ I tried it and it works perfectly. In case anyone else is annoyed by the curser always in your face in VR.

1 Like

I found it simple enough to look down, move the mouse, and that would be sufficient to leave it out of sight until it timed out and disappeared properly.

1 Like

Hi there

I find the middle mouse button (press the scroll wheel) makes the pointer appear/disappear

Hope this helps

1 Like

Ah, maybe that’s my problem, I have a trackpad with two buttons and not a standard mouse. However, if the middle button, as you stated, toggles the mouse cursor then it must be a binding that I’m missing.

Glad you’ve got a workaround Jeff, as far as I can see if you have a regular mouse the cursor has no problem disappearing after a few seconds, it’s a pretty neat solution from Asobo.

1 Like

Hi all,

The key binding is ‘Toggle Cockpit Freelook’. This is bound to middle mouse by default. In normal operation just moving the mouse should make it appear and a few seconds later it will fade. I found this doesn’t always happen with a trackball mouse but the middle button option always works.

I agree with @sneaky74 that Asobo/MS implementation of their VR cockpit is very good indeed, beats Xplane and DCS hands down.

1 Like

I think waiting 5 seconds before making a mouse cursor disappear is too long.
Especially when I’m recording the game, or when I’m in VR
In fact in VR, everything that appears in front of your eyes is disturbing (cursor, popup text info …). This breaks the immersion, and often even too huge
In drone view, if I want to move the axis with the mouse, the indiscreet cursor pops and returns to the center of the screen before finally disappearing after 5 boring seconds of flight …

From this thread, no easy way to reduce the time until the cursor disappears, I guess?