High Manipulators

My system info:
Operating System: Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
Processor: 11th Gen Intel(R) Core™ i7-11700K @ 3.60GHz (16 CPUs), ~3.6GHz
Memory: 49152MB RAM
Display Card: NVIDIA GeForce GTX 1080

The Manipulators cause my menus to be clumsy I need to click several times for commands to be processed.
image
1
This is a record I guess 15651.1 ms
image

I been running on clean boot, no change

Any one with similar issues? any advice?

Yes, same for me, my manipulatiors are in the high 40’s to low 50’s. It wasn’t that high ever regardless of the area I was flying (KJFK/KDFW/KLAX/KLGA) or the aircraft. Now no matter where I fly and what aircraft I use I get the same high manipulators and very low FPS. OK maybe if I fly a glider in the middle of nowhere and no traffic it will be lower with better fps but something is seriously wrong with SU11’s release. My belief is that Live traffic is somehow screwing this up. LOL trying again and the manipulatiors are 500??? 2.2 FPS while loading a new flight, this is just nuts. Even with an empty community folder and a fresh install this morning updated to Beta .29. I’m going to try and reboot again as 2 fps is just not right?

Shot in the dark…
But try increasing the render resolution towards 2160×1440…
Also noticing that ram value…have you double checked that the matching sized modules are in the correct slots…ie same size chip, same color ram slot.

Obviously your Processor could be paired with a more capable gpu. If/when you upgrade gpu DON’T go under 12gb vram…anything less is becoming obsolete

Thanks for your advice.
As Im on GTX1080 I dont think I am able to increase my resoluation beyond 1920X1080

My ram setup is fine
image

You definitely can (spoken from experience) run at 2160×1440…you have your settings in sim way below what they can run at.
Increase the render scaling up towards 2160x1440 and set the overall settings to high.
I personally have seen a gtx1080 paired with an old i5 set higher settings and at 2160x1440 native.

Adjusting the render scaling did not reduce the manipulators!
Spikes at 850+ to 1100+


Lows at 30+

I have no issues when flying, my problem is when I hit ESC to go menus I have to wait ages for the menus to appear and ages for a command to be processed (when I click on something).

Something definitely weird going on…your system specs even with gtx1080 shouldn’t be having issues.

I have personally installed and tested/played on a system with a old i5 (2010 or older) with 32gb ram and a gtx1080 almost all settings on high @2160x1440 and it is overall smooth gameplay and no lag going through and to the menu’s.

Do you have the specs for you ram (size, manufacturer CL speed) the 16gb vs the 8gb chips…are they same speed?

Have you monitored your temps while simming?
And sorry if already asked…did you set game exe to run at high priority?
Finally how many programs do you have set to run at startup of windows?

Also, try giving DX12 a try

This is going to be lengthy but hopefully helpful.

Things to check:
(System)

  1. What performance mode is windows set to (recommend performance or ultra)

  2. HAGS (i am now reading people benefiting from having it set to on, so try both settings with a reboot after setting then test)

  3. Ram speed (in bios is it set to xmp profile? Recommend xmp if possible)

  4. Virtualization (bios) recommend OFF

  5. Once sim is running Open task manager and select the flightsimulator.exe right click and select Go To Details. Right click the .exe again go to Set CPU Priority and select High. If you see improvement with this setting and want it to always load with High for its cpu priority setting, you can download and install an app call Prio process priority control. Once you have that installed, then reboot pc, run msfs again then open Task Manager again following the steps above to set the CPU priority to high. That’s all. From now on prio will automatically set the exe to run in high priority.

  6. With Task Manager open go to Startup tab and disable any and all programs (non essential) to your system) for instance i have everything disabled except my rgb lighting software, external soundcard driver, voicemeeter and Nexus app.

(GPU settings)
Recommend following this guide specifically the power setting.

Finally I’d recommend looking at the temps. Take off side panel and see if performance becomes more stable. I have an open air case with multiple added fans…fans blowing on chipset, ram, north & south bridge…heat is the “enemy” so i say minimize it wherever possible. No need to add fans…but consider opening the side panel while simming…i definitely notice more heat generation when playing msfs then with most other titles i play so i can imagine the heat in a closed case system gets up there.

Hopefully these suggestions will net you a performance/stability gain.