Honeycomb alpha flight control oscillates Y-axis

My new Honeycomb alpha flightcontrol, calibrated with Win10, oscillates in the Y-axis. You can’t fly with it!
Can someone help? Thanks.

Did you plug it into your motherboard or via a usb hub?

If its the latter, try plugging it in your mobo directly and see if this fixes your issue.

Cheers Mark

I’ve tried both. The effect was the same! Greetings

Haven’t done research myself, but see if you can find a way to recalibrate the device. Maybe that will help.

Have already done the internal calibration - without success! Now the question is: the new Alpha yoke is defective or is it my system PC or MSFS?

Good question.

Do you have anyone closeby with an Alpha?
Try swapping them and see if the issue persists.


Since it also doesn’t work in other flight sims like DCS, the potentiometer seems to be bad or dirty! I have to exchange the Alpha.

Sorry to hear this :slightly_smiling_face:

Given some reported comments on customer support maybe it would be best to start the return process as soon as you can?

Not trying to tell you what to do, only trying to help :slightly_smiling_face:

This is the reason I updated to the XPC. The Hall sensors are very good and precise. Couldn’t stand the chattering in my Alpha.

That could be the case as well indeed.
Let us know your findings after you have tested a new one.

All the best.


I have the same problem. Tried using Spadnext axis calibration and it helped a little but you have to widen the dead zone so much that it makes the axis non-existent. I tried contacting support at Honeycomb but they are non-existent as well. My thoughts of Honeycomb Aeronautical have changed dramatically since then and I will dissuade anyone from purchasing a product from them.

This is a defective potentiometer. I was able to exchange the Alphajoke from the seller!

Forget about customer service at Honeycomb, someone forgot to pay a large bill, their done.