Honeycomb Bravo Throttle and SU5


Anyone is experiencing some troubles with the Honeycomb Bravo Throttle Quadrant since SU5 ? it seems that the update has destroyed my throtlle Axis.

It’s a nightmare to rebinding them and to work properly with any aicraft.

A few of us are getting similar issues with our hardware:

Hello @ZeroHyperion902 ,
I have tested axis 1,3,4 and 6.
At least those do not have any issues with my set-up and SU5.


Thanks for the the feedback.

I tried to bind the axis followîg this video

But the the reverse axis and decrease buttons are not working any more
( the sim detects them)

1 Like

So not the axis, but the reverse button detent on the axis/the reverse leaver is affected?
I don’t think I have them mapped in the sim, but I can use them via simconnect.
So I can not comment, if this is working or not with MSFS bindings.

I noticed that the trim wheel working as it should again.

1 Like

I have read that very many people complain about hypersensitive trim, so I am afraid that this fix for Bravo will only be temporary, I recommend everyone who has used vJoy fix not to uninstall it yet.

This SU5 has made the Bravo unusable. I loaded up the Cub, and the single throttle works, but nothing else. And un-binding the controls and then re-binding them shows them to be found, but they will not activate. I have heardof many more problems with certain aircraft, but I have to fall back now on my X-56 HOTAS in order to fly!

The Bravo works for me. . Are you sure you have the AFC_bridge drivers installed?

My driver is dated 1/18/2021. Is there a newer version?

Reloaded everything…Bravo still not working. I have axes 1. 2 and 3 working, but noone of the switched on all axes or switch panel.

1 Like

I have a different problem with the Alpha and Bravo. When I tried to change a key binding on the Alpha, MSFS froze. I restarted the program, I have unplugged the Alpha and plugged it back in, but it has not helped. I tried to change a binding on the Bravo and encountered the same issue.

I suspect this is another casualty from update 5, but if anyone has any suggestions, I would appreciate it. Thanks!


Make sure you have only the devices connected (i have keyboard, mouse, honeycomb,bravo,alpha and Saitek pedals) you are using in the sim. I have my extra Saitek hotas and throttle disconnected. (I use a usb hub…). When i have the extra hotas and throttle also connected i have also axes trouble :thinking:.
When i need to use the hotas and throttle (flyinside bell…) i have to disconnected the bravo and alpha. Maybe MSFS has limited or to much devices? or they conflicted?

1 Like

The Afc bridge is not necesseray (unless we want the leds to work), i’m talking about the axis and binding them

i’ve got no issues here with the bravo. The trim on the bravo is working much better than before, but might be a tiny bit too sensitive now. I’ve configured the bravo with much the same profiles as in that youtube video (https://youtu.be/9xv3BEjysyQ) mentioned here before.

i can confirm on my side that single engine prop (throttle and mixture) are working for me, as well as single engine complex (throttle, rpm and mixture) as well as the 2 engine jets and airliners. With the a320 fbw i did have to do calibration in the flypad/efb on the development version of the fbw mod (which is the only one compatible with su5). i havent tested the 4 engine layout yet, as i haven’t tried the 747 :slight_smile:

I have the same problem with the Alpha and Bravo. Sim freezes. I submitted a report to Zendesk and hope to get a resolution.

1 Like

Not really! I have null devices set up for every controller, so I never disconnect them, I just switch over to the null (empty, no bindings) to remove the stuff I’m not using. And prior to SU5, I had the X-56 throttles nulled out while I used the joystick, and there were no problems with the Bravo.

Same here. No issue. Are the freezes not happening when you disconnect the Bravo? Because I think it’s happening for a lot of people with a lot of different hardware, which may point to something altogether different. I use to have constant freezes in VR on the days after the update but not anymore…Maybe the infrastructure was brought to its knees by the 40gb update + xbox release.

Thanks much!

It might not be necessary, but it sure adds to the realism and fun of the throttle quadrant and it doesn’t work on the latest build