HoneycombBravo USB not recognised by USB on set up

Cant setup my Honeycomb Bravo controller
When i connect my Honeycomb Bravo to USB port on my PC I get an error message saying its malfunctioned and not recognized. Unknown device with driver error also shows under game controller menu.
Tried different USB ports, powered and unpowered ones - none will work.
My Alpha controller works OK. An exe.xml file(I assume this runs the controllers) appears under C drive >>>>Local cache folder.
Can anyone help??
Thanks very much

Hi SpecularCloth92,

We are sorry to hear you are having issues with your Bravo Throttle.
Can you create a ticket here:
When that is done, if you can reply me your ticket number we will get you sorted ASAP.

Best Regards

Thankyou.I have now done this.
Kind regards

In my experience USB ports on the motherboard can be woefully under powered. Sometimes a powered USB hub can resolve issues.

Does your Bravo show up if you unplug all other USB devices (sans keyboard and mouse)?

Not tried this but I will.I wondered if power setting was a factor having read other posts

Also have a look at this:

Thanks very much.
Ill try this as well.
Much appreciated
Kind regards

Along with above, try this second.
Right Click “This PC”, or go to manage or find Device Manager. Go down to USB Controllers and start at the bottom of the list, and delete then by right clicking on each entry, and choose uninstall. Eventually, the mouse will stop respondince and some of them take a while to be gone. Shut down PC, unplug power cable, then push power switch (desktop assumed-laptop if remove battery is possible, if not just remove power cable). Wait 30 seconds, plug in power cable and restart pc. All usb devices in Device manager will be restored, and they all should work now. Good advice on powered USB hub, however, it helps if the hub is plugged into a USB-C port if you have one, because they operate at 10GB speed, and can carry bandwidth through it to hub. Now, I initially had HC-BTQ plugged directly into my PC, and experineced no issues, but with TQ, Joystick, Keyboard, extra 8TB harddrive, needed hub for it all. If you can support one, I use this one off amazon.

AmazonSmile: USB C HUB, Upgraded TOTU 13 in 1 Type C Hub Dongle Adapter (4K Dual HDMI&DP,75W PD), Triple Display Docking Station for Windows&MacBook Pro USB C Systems, macOS only Support Mirror Display : Electronics

It will take an external power supply if you are running 3 montors, otherwise not needed if coming out of a USB-C port, if not, not sure what to do. If desktop, and you have extra empty slot, aftermarket USB-C port device if necessary, Do research first. Might be internal card which has bunch of USB ports on it, If laptop, no suggestions. Hope this helps.

I found the problem is a faulty usb cable supplied with the Bravo.I swapped cable with my Alpha and it works.
I bought a better powered usb hub which was probably not necessary but is better anyway.All the suggestions supplied - and more - were tried anyway but thankyou to all for your help.
Waiting to hear if a new cable will be supplied
Thankyou again.I have learnt a lot more about device manager and usb issues

Same problem for me. Went through everything for like 2 hours and nothing. Swapped out the brand new usb cable that came with the yoke and everything started working.