Horrible stutters

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.


Brief description of the issue:

It happens randomly, can be in the middle of a flight, start, or end. (I’ve updated all add-ons even though it happens even without them) I’m looking for help here because MSFS support hasn’t been able to resolve the issue so far.

Provide Screenshot(s)/video(s) of the issue encountered:

Watch Microsoft Flight Simulator 2024-02-01 09-46-18 | Streamable
Watch Microsoft Flight Simulator 2024-02-01 09-46-00 | Streamable

Detailed steps to reproduce the issue encountered:

It happens randomly.

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version (Learn how to find your current graphics card driver version):


PC specs and peripheral set up:

RTX 4050 i7-13620H 15,73 GB Ram

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:


Build Version # when you first started experiencing this issue:

3 months ago.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Wow these are heavy, never seen this before.
Did you changed setting on devices or keybinds
I seems to me as if something conflicts onto priority or so



I haven’t changed any keybinds or anything like that, I was using an Xbox controller when that video was recorded. But now I have yoke and throttle and the problems is still the same.

omg!! what the hell is that??

Are you referring to the rapid movement of the camera in those two videos as “stuttering”? The rapid movement looks more like a peripheral / controller mapping issue. I’d suggest, if you have not already done so, to:

  • Double check the bindings on your controller(s) to make sure you don’t have the camera bindings accidentally mapped to non-camera functions as well.
  • Try disconnecting your controllers & using only the mouse & keyboard with their default settings (not any custom ones you may have created) & run a few test flights. Doing so will narrow down the issue. If it is still occurring, we can rule out a problem with your peripherals and look elsewhere for the cause.

Sorry for asking but what do you mean by “don’t have the camera bindings accidentally mapped to non-camera functions as well.”

Cheers for the help!

No problem - I should have been more specific. An example of bad mapping:

Note how Translate Cockpit View Left has somehow got mapped to CTRL+1. Whenever I press CTRL+1 to increase the Com1 frequency, this also moves the cockpit camera viewpoint. Not good!

Thanks for the reply! I’ll check if mine is like that. The only thing is that I don’t use my keyboard expect for the insert button for custom camera views. Maybe Alt and Tab causes the conflict, when I’m changing tabs.

Under controller options, for each controller (keyboard, mouse, joystick, etc.) enter “cockpit” in the “search by Name” box and set the filter to “Assigned”. Then review the settings for anomalies.
[Edit: I also remove all of the default settings that I don’t use, to minimize conflicts. It also frees up setting options for things I do want to control :slightly_smiling_face:, but that is just my personal preference.]

Alright, I’ll check this out, thanks for the help!


This is basically it , I don’t have anything else except for the yoke and throttle. I deleted everything for the keyboard because I don’t really use it.

Looks good. I think we can rule out peripherals. I just noticed this was posted in another thread:

in it RagingWombat839 goes on to say:

The description reminded me of what you are seeing. What do you think? - Are you using DX12 with framegen?

1 Like

For what it’s worth, I get this stuttering/jittering about once every month or two. Doesn’t matter which plane or airport I use. If I back out of the flight and restart or do another one, it will happen again. Only after exiting the sim and then restarting the sim will it go away. My PC specs are in my profile.

Yes that is exactly what it looks like.

@jijid4 try pressing alt+enter twice, that should fix it, until it happens again. Turning off framegen is the only permanent fix at the moment. I’m sure there is a bug thread for this somewhere but search is failing me right now.


Hey, looks like it, I’m using DX12 but not sure about the framegen.

I’ll try that thanks!

Just tried that, it works perfectly. Thank you so much!

1 Like