Hotas Warthog "jump" issue

Hi All,

Since last update my throttle of my Hotas Warthog is jumping when on idle. This happens after the last update. before working flawless. Try couple aircrafts and same problem. Calibrated via windows.
When using in X-Plane, I have no problem.

Any thoughts?

Thanks!

Usually a sign that the potentiometer is worn or going out. There’s some sprays/deoxits you can try, but eventually it does mean replacement.

The warthog throttle does not have potentiometer. It works with hall effects sensors on the axis.
Maybe it might be a sim calibration issue. I would check the settings for it and maybe add and set new in the sim.

Thanks. Just tested on windows calibration and XPlane 11 with no flaws. And indeed no pot-meter in throttle.

Just purely a MSFS 2020 problem. It is kind of weird that after the update the problem occurs. Before no issue at all after lots of hours flying

I’ve seen the Warthog stick, it’s a Hall Effect. But the throttles don’t have Hall Effect or H.E.A.R.T. featured on their pages.

Just tried out couple things and found a solution. It turns out that my CH Product Flightsim Yoke was acting as a “Noisy Neighbor”. I unplugged all USB devices, except the warthog discovering the problem.

So deleted the Flightsim Yoke and added it again. Made a testflight with C172 without a problem now. In the evening testing with the A32NX.

Thanks for thinking along!

1 Like

As I was glad that it was solved, it was temporarily. Since the new update I experience jitter on my pedals to. Change USB ports, etc, etc. But still the problem exists.

In sensitivity setting, I don’t see that happening. But as soon I go back to the airplane, the problem is there. For example, when I apply rudder (left or right) it is jumping.

As stated, I don’t have that problem in X-Plane 11. Tested on several aircrafts including ZIBO Boeing 737. Everything is working fine.

After testing tonight with several settings and swapping controllers, I finally made progress in tracing down the issue and it seems to be solved.

Just to clarify. have a Hotas warthog, CH pro yoke (with single throttle lever) and pedals and normally next to it a logitech joystick for drone purpose only.

Now hopefully the solution to the problem I got. My CH yoke is often not working directly in MSFS 2020 when i wanted to fly. In device settings of W10, it is then stated unrecognized. So what I normally do is pull the usb plug and reconnect.

The last time I did this was it not working again and therefore try to remove the warthog and the logitech. When reconnecting the warthog and logitech, I didn’t pay attention enough when MSFS 2020 asked: Do you want the default or current setup. What I remembered now is that I have chosen DEFAULT.

The result of this, both warthog and logitech have default throttle, and display setting etc. So when i reconnected the next time the logitech again the small throttle lever was in mid position and that caused jumping.

I have still to check settings in various profiles but hopefully that solved it…

1 Like