How Do I Acknowledge ATC Comms?

How do I acknowledge ATC COMMUNICATIONS in Xbox? My flight was setup with AI ATC Communications.

Click on the ‘Tower’ icon from the top menu. That will open up the ATC communications window.

Thanks. I was hoping that there was a one button way of doing it. I was far into final and didn’t couldn’t take the time away from the controls to go through the steps to enable the top menu.

I have changed most of my key bindings, but I’m pretty sure that, if you check out these, there should be in the keyboard section some key binding that lets you select the options presented by the ATC.

Acknowledge option is usually the first one, so whenever you hear the ATC and you want to acknowledge you press the shortcut for ‘option 1’ and that’s it. No need to even open any menu.

On the other hand, I have also a shortcut in my joystick to open the comms menu to keep it handy, so I can quickly press it and select the one I want with the mouse, for those cases when I want to see what options are available, etc.

There are bindings ‘respond ATC option 1/2/3/4/5/…’
I have TMWH coolie 4-way bound to 1/2/3/4, always have ATC open for 0/5/6/7/8/9 with mouse

1 Like

I’m using an Xbox with and Xbox controller. No mouse or keyboard.

You can attach usb mouse and keyboard? (And lots of stuff? Buttonboxes? a USB hub?)

1 Like

Keyboard and mice are supported. I actually attached a Logitech wireless receiver to the Xbox X and was able to use my Logitech wireless mouse and keyboard with the sim. Made flying the A320 a lot easier.

I have no current plan to add mouse & keyboard, so I’m looking for an ATC solution with HOTAS and Xbox Controller only.

There simply isn’t time to start faffing around with cursor modes when on approach.

I’ll accept a ‘simplified’ scheme on Xbox and I have ‘AI ATC’ enable so that the co-pilot replies for me, but the ATC sometimes gets fixated.

First when I’m on approach at around 3,000 feet and ATC wants me to be at 10,000.

Second, when I’m on the ground and ATC wants me to tune in again to access taxiing.

I have my hotas on my knees, the controller is leaning on my belly, where would there be room for a keyboard/mouse anyway? :slightly_smiling_face:

1 Like

Lol i like your style, you have definitely chosen the right gamertag🤣

1 Like

ok, I’ve had a bit of a breakthrough. I do have this ‘chat pad’ but that didn’t solve the problem of ‘active pause’. But I found the ‘pause’ setting in the controls and mapped it to “P” (pause) and it works.

So I can now use the number keys to talk to ATC. Though I still have no clue why they want me to climb to 14,000 feet whenI I’m just about to land. :thinking:

The base sim ATC can be a bit hit and miss, especially if you’re using high or low airways. Just ignore it if it’s doing a dumb-dumb :slight_smile:

1 Like