HP Reverb G2 jumping between MSFS2020 and WMR



I’m complete new to VR and just got my first headset (HP Reverb G2), especially for msfs2020.

But I have an issue, so far haven’t manage to get VR mode to stay on, it keeps switching to WMR then back to MSFS then back to WMR etc until MSFS finally crashes and I’m left with WMR running.

Played around with all my settings based on a few videos that were posted on this forum and even lowered everything down to minimum in case its performance related. Downloaded OpenXR dev tools and configured as instructed in some videos.

Followed various startup procedures that I found on this forum but still nothing.

Issue happens only when I enter a flight or enter VR while in a flight, VR while in menus works fine. As soon as the flight starts (before you press ready) it starts to switch back and forth to WMR until crashing.

PC Specs

PC is also freshly formatted with latest Windows 10 Pro 20H2

I’m sure its a setting/checkbox somewhere but I just cant find it.

Thanks in advance for any help

I have a similar problem. The g2 works perfect with high frame rates. Every now and then when the going gets more intense, the screen will go black and freeze. After a minute or two, it will continue as normal with high frame rates. It seems even lowering the graphics will not stop this intermittent freezing. I have a I9 system with a RTX 3070.

This blackout problem with G2 is very common. Check out my earlier comments in the issue.

Hello @oCharlis ,

I had a similar problem… in my case, the issue was my ATC window that was not in the main (game) screen. I use two screens, and pushing the ATC on the second one just crashes the VR.

Hi @Theduck38 ,
Yes, that was exactly my issue also but with VFR Map, worked it out the other day. Seems that any pop out window crashes the VR, bit silly really as I was wearing the headset and wasnt noticing the popout window - lol

Thanks for replying.

1 Like

Having the same problem as the first post. Extremely disappointing to have invested in the HP Reverb G2 and haven’t been able to enjoy a single flight in VR. I’m running AMD Ryzen 7 3800X 8-Core Processor 3.89 GHz, 16 GB RAM, GPU is NVIDIA GeForce RTX 2070 Super.

Everything runs fine until I attempt to switch to VR mode from MSFS. Then, it just jumps back and forth between MSFS and Windows Mixed Reality and finally crashes, leaving WMR running.


Have you any game window (like ATC, map…) on a second screen ?

@TheDuck38 Got to the bottom of it:

  1. According to HP Support, this is a known issue and a case had already been escalated to AMD.
  2. HP had me update my chipset driver.
  3. Made sure the driver for the graphics card was up to date.
  4. Like TheDuck38 said, I opened MSFS without VR closed all ATC, Map, Flight Plan, etc. windows which were displaying on my second and third monitors. Then started VR.

VOILA!! Solved.

I have the same Issue. Did anybody found a solution yet? Please let me know.


Did you read the two above posts ? Do they solve your issue ?

I had the same problem. After activating VR in Flight or after changing from Menu into Flight, it keeps switching to WMR then back to MSFS then back to WMR etc until MSFS finally crashes and I’m left with WMR running. My solution was: simply deactivate “WASM-Load Modules Asynchronously” in the Developer Tool. It was implementet with the last update under “Options” (last point). Before the last update, everything worked fine. So I found out in the update diskription, that this was a big change in the developer tool, and it was activatet after update. So I hope, that this will help you going back flying VR.

SheriffLTG63 and All,

I have the same problem. But when I go to General>Developers>Developer Mode, I get no further choices. Where is “WASM-Load Modules Asynchronously” so I can deactivate as you suggest.

With the latest updates (World update 4 and you should have a Change in the SDK. So activate the Developer Mode in the msfs, then go to the top of the screen (DEVMODE) and open „Options“. The last point in this menu is „Load Modules Asynchronously“. Then deactivate it.
Please let me know if this has solved the Problem.

I followed the exact steps but unfortunately it did’t help :frowning:

Wow, it made a difference in my rig. 3800X 32gb M.2 RTX3070. A little tweaking left to do (stuttering once in a while) but way better with higher textures.

Hi, this is my first time on this site…came on to see if anyone could help me? I have just purchased a HP Reverb G2 for MS 2020 and I am having same problem as already listed, I keep getting the screen full of the white triangles as it tries to switch into FS 2020, only for it to keep doing it over and over until FS 2020 crashes. I thought that purchasing an headset that suited this simulator would make for a smooth transition into VR but obviously not, ironically X Plane 11 transitions into VR as smooth as silk on this headset. I noted all your post and will give the one regarding the “Load Modules Asynchronously” a try but if anyone has further remedies then please let me know.
Kindest regards to all.


Do you have any game screen (like ATC or map) that could be outside main screen ? If yes, just use 2D mode to remove them and then switch to VR.

I also had the problem that the image in the Reverb G2 switched between msfs2020 and WMR. All drivers were updated, all settings in OpenXR, in MSFS2020 and WMR were tried, nothing helped. In desperation, I contacted the (Dutch) HP helpdesk by telephone. They solved my problem by sending me an SPS-USB Hub & USB Dongle Kit (part number M44588-001) without any problem and absolutely free of charge. That thing has a value of €62.00 and I received it for free. I am very grateful for the good service from HP, my problem is solved.

1 Like