HTC Vive Cosmos Elite not working

does also not work for me. Maybe it is also a difference with the version from Steam and Microsoft app store. Because my version is not visible in viveport.

Hey guys,

Can I suggest trying in this order
Load msfs2020 - make sure vr mode is off - when at the menu go to your hmd on steamvr home and press the options button - click the reset seated/standing position button at the bottom right corner - once it has reset go to msfs and enable vr mode.

This has worked for me for 3 days running now so hopefully this helps guys

2 Likes

Works fine for me… sometimes it’s black screen. Only fix for that is for me to turn off vr mode and put the headset on, so u see steam vr background and then activate vr mode again.

But off topic I got really bad performance with my cosmos. Drains cpu power extremely much… I got 9900k 4.9 ghz any one knows how to fix this please let me know.

1 Like

That does the trick for me as well. Although had to do it each time I played - might have been something to do with the game crashing.
Now to resolve the jittering .

1 Like

Here is a temporary solution that works for me…

If your Vive headset does not work in MS FlightSim 2020, (the Vive headset display is 95% covered by black circles), then opening the OpenVR Advanced Settings module fixes it for me.

Step 1) Install the third party OpenVR Advanced Settings module for the Vive Cosmos Elite.
Step 2) Run the module. Just running it (starting it) seems to fix the headset problem.

README: https://github.com/OpenVR-Advanced-Settings/OpenVR-AdvancedSettings#readme

DOWNLOAD PAGE: https://github.com/OpenVR-Advanced-Settings/OpenVR-AdvancedSettings/releases/tag/v5.3.1

DOWNLOAD: “AdvancedSettings-5.3.1-Installer.exe” file for Windows 10.

From there I can get more access to resetting many OpenVR options. When running the Vive control panel, there is a new ‘Advanced Settings’ circle icon/button in the bottom left (the 3rd icon along from the left)

The result is that the Vive Cosmic Elite headset is working again. After a few plays of FlightSim the Vive headset is 95% filled with black circles again. But, by running the OpenVR Advanced Settings module again, the problem is ‘fixed’ again. Better than broken all of the time.

MS FlightSim appears to scramble some headset view settings (not simply a headset reset/default position issue) and the Advanced Settings module resets something for me.

See also this post in the Bug area from lowdowndan:

This worked also for me.

Unfortunately, setting the “Always show Floor Bounds” to on still does not work for me. I tried to install the OpenVR Advanced Settings module, and whilst I wasn’t able to fix the problem, I did notice something. For all of the other games, the tracking universe is set to standing. However, in MSFS, the tracking universe instead gets set to “unknown” and I am suddenly unable to adjust the position settings.

For me in the OpenVR Advanced Settings, in the Offset menu tab on the left, the Tracking Universe shows as “Standing” when the headset display is working in MS Flightsim.

Aways show floor bounds on, working for me cosmos elite :+1:

I think this is definitely a bad sign. Have you tried running the Vive Room Setup again?

By running the OpenVR Advanced Settings module fixes the problem for me (until the Headset view breaks again), and repeat the process of running the Advanced Settings module each time.

1 Like

I redid the room setup and it now works, thank you!

Regardless, this issue still needs to be fixed. It’s unacceptable to have to navigate through all of these hoops just to get the headset working.

1 Like

Hi All,

Same issue for me.

I have a Vive Cosmos Elite.

I believe I have tried everything that I’ve seen on various posts, including:

Beta SteamVR

Beta Vive Console - Also tried a private Beta I saw in a diff post

UPDATED VIVEPORT

RESET HEADSET

LAUNCH FROM VIVEPORT

RESET SEAT POSITION

Turned off Theatre mode

Plus many more.

Once - and only once, it worked but the image was upside down in the headset - I thought I’d reboot and that would fix it and my problems would be over but no, after re-booting (and not changing the settings which gave the upside down image), it went back to the largely black screen and a v small image in the top right and bottom right extremes when looking in those directions.

no matter what “fixes” i’ve tried, +99% of the time, it’s the black image with the v small image in the top right and bottom right extremes when looking in those directions.

Any other assistance/thoujghts would be appreciated but I’m thinking this will require a patch to fix it - IMO :slight_smile:

1 Like

I guess I’m a bit of a sucker for punishment - tried VR again tonight (here in Australia). I repeated something I’d tried previously without success and that was to:

  • In Game but before pressing CTRL+Tab to enter VR, press the “button” on the left hand side of the headset to enter the headset menu.
  • On the bottom right of that screen, select the “Reset Standing Position” (this disappears after you’ve entered VR mode so do it beforehand).
  • Then enter the game again and press CTRL+Tab to enter VR mode.

This worked for me and I’ve just played in VR for the last three hours!!!

I also exited the game, and re-loaded it. For “fun”, I entered VR mode straight away and had the same issues as previous but then exited VR mode, followed the steps above again and it worked again.

I had read this previously in this thread and tried it without success last night (not really sure what was different between then and now) but it worked for me this time :slight_smile:

Thanks to Dekks84 for the tip!

Did you try:

Installing the third party OpenVR Advanced Settings module for the Vive Cosmos Elite.

I document it above in this thread. It fixes the black headset problem for me every time.

Hi - I did but it didn’t work for me. Now that I seem to have a repeatable process that works, I might re-run OpenVR before starting the game and seeing if that cuts out the other steps.

Thanks for replying :slight_smile:

Hi. I had the same issues.

Installing the betas for vive elite and steam fixed the issues after a lot of reading.

Also added openxr but unsure if it helped.

Same problem here - anyone got in touch with the Helpdesk yet?

Okay - so I thought I had it sorted with the steps I mentioned earlier but I didn’t. Spent a few frustrating hours a couple of nights ago trying to get the settings right to use VR again - without success. I logged a support ticket via Zendesk - haven’t had a response yet.

Tonight, I tried again and the following worked. This is after having the Steam Beta and OpenXR installed.

  1. Ran MSFS 2020 via steam
  2. Pressed CTRL+Tab to enter VR mode (had the black circles)
  3. in Game, pressed the button on the side of the headset to open the Steam VR Home menu
  4. Pressed the settings button (cogs) bottom right
  5. From the “Play Area” Menu Item in the left hand menu, I turned “always show floor bounds” to on
  6. Selected “Home” from the bottom middle of the screen
  7. Selected return to Game
  8. Black Circles were gone

I went back in and repeated the above and turned “always show floor bounds” to off, went back into the game and the black circles were back. Repeated the above steps and it worked properly again.

Hopefully the “Always show floor bounds” setting to off sticks. I’ll find out soon enough I guess.
Changing Always show Floor Bounds to on has been mentioned previously, just wanted to share that this worked for me…

I’m putting the blame on the last update. All was perfect with my Vive Cosmos Elite, now most directions I turn/face in VR mode I am hit with the fisheyes.

OK, so maybe I was too quick to blame the latest patch.

I did some more playing around and can confirm, for me at least, that having floor bounds turned off is one cause of this problem.

I also tried to reset the standing position while standing in the centre of my available play space and I don’t seem to have the view mucking up now.

When I reset my position while sitting in my chair, the view then mucks up when moving my head forward a few centimetres. Perhaps there is some strange boundary problem the sim is having trouble with.