HTC Vive Cosmos Elite not working

Running SteamVR, running MSFS (digital license from MS Store), switching to VR, everything is ok, I can see the splitted screen on monitor, I can see correct preview in SteamVR, but when look into headset just black and partial white part with grid up & down. From time to time (when moving my head), I can see the screen correctly, but just for a sec, then black again. Tried to disable HDR, tried to reset sitting position, but no change. Any ideas please? Really looked forward to this VR update :slight_smile:


I had the same issue, I thought resetting my seated position was kind of fixing it, but it didn’t really work. When I leaned forward far enough, then I could see everything normally. I did a reset on my Cosmos Elite through the Vive Console, but now I just get some weird fisheye kind of window with everything on it way in front of me. Don’t really have a solution for you, but don’t reset your headset, I think that made mine worse.


When launching VR mode, I see the same issue.

Vive Cosmos Elite

Microsoft Store edition of the game

Beta SteamVR

Beta Vive Console

Also tried all suggestions OP tried as well.

Definitely feeling the big sad right now. :frowning_face:


Me too.

I had it working for an hour then today when I try my Vive Cosmos Elite the headseat is fisheye covered 95% by big black circles.

I know the Vive system is working ok as other VR applications like Apollo 11 VR are working fine as before.

From time to time (when moving my head), I can see the screen correctly, but just for a sec, then black again.

Yes, I get the same here.

One way to fix it is to load the Steam popup and choose Settings and then switch the Play Area “Always show floor bounds” over to ON.


I have the same issue. This is realy bad. It seems nobody has tested it with Vive Cosmos Elite…


I have the Cosmos, but not Elite. Everyting is working well here. I had to reset seat-position in steam once though. As the Menue was behind me. Maybe recalibrate the room in vive console helps. I use seated position, as I dont play other games than sims.


This is how I can enjoy the game on my HTC Vive cosmos elite:


Unfortunately reset seat position also did not work. I have also setup the seat position.
My MSFS 2020 version is from the Microsoft store directly.
My system: Intel Core i9 10850K, nvidia geforce rtx 3070, 32 GB Ram.

1 Like

I have exactly same issue. Donne all the possible suggestions all the betas, disable cinema mode, reset room settings. still fubard. when switching to VR Mode it blinks and it looks fine for a sec and then the image shifts to a weird angle to left and down. although on screen it shows like everything is OK
Sooo disappointed at the moment


*DEC 28, 2020: I have now posted a temporary fix to this problem further down this thread.

The first thing to try is to open the SteamVR Settings control panel - choose Play Area, and turn Always show Floor Bounds to ON.

Yes, you get less than a second of it looking ‘ok’, then the headset view shifts to something that is 95% black. Unusable. It looks like the ‘view’ angle data is completely screwed, and there is no documented way to fix it.

I think the bug is definitely in the latest MS Flightsim 2020 update that I got last night (22 DEC 2020). It breaks HTC Vive Cosmos Elite headsets.

You will go crazy trying to fix it from the SteamVR/HTC side. I guess we either need to find out how to reset the MS Flightsim headset data files or wait for a bug fix from Microsoft.

I even tried installed the newest Vive beta software. Same result. The BUG is with MS Flightsim 2020.

Vive Beta
Tested with SteamVR 1.15.15 and 1.15.16


I have reported this to Zendesk. Still waiting on a proper response. Was given instructions about fixing the Occulus headset software after my initial report, when I clearly stated I had the HTC Vive Cosmos Elite. Won’t be doing a run around with Microsoft on Christmas, will be spending time playing other games. Games are for enjoyment not to be a chore.

1 Like

Cosmos user here. I’ve just replaced my Vive standard with the Cosmos, and I’ve just run into the exact same issue.

Got it to work with the Cosmos Elite made an account just show I can share the love. Make sure all these steps are done.

Beta SteamVR

Beta Vive Console




Runs great with no issues for me. RTX 2080TI, I9 9900K OC TO 5.0 GHZ 64GB DDR4 RAM

I tried un-installed Steam (and Steam VR) and the Vive software and re-installing it.

Same problem - the Vive Cosmos Elite does not work with the latest version of Flightsim 2020 (as of 26 DEC 2020)

I am fed up paying money for ‘beta’ software from Microsoft.

That did not work for me.

does also not work for me. Maybe it is also a difference with the version from Steam and Microsoft app store. Because my version is not visible in viveport.

Hey guys,

Can I suggest trying in this order
Load msfs2020 - make sure vr mode is off - when at the menu go to your hmd on steamvr home and press the options button - click the reset seated/standing position button at the bottom right corner - once it has reset go to msfs and enable vr mode.

This has worked for me for 3 days running now so hopefully this helps guys


Works fine for me… sometimes it’s black screen. Only fix for that is for me to turn off vr mode and put the headset on, so u see steam vr background and then activate vr mode again.

But off topic I got really bad performance with my cosmos. Drains cpu power extremely much… I got 9900k 4.9 ghz any one knows how to fix this please let me know.

1 Like

That does the trick for me as well. Although had to do it each time I played - might have been something to do with the game crashing.
Now to resolve the jittering .

1 Like

Here is a temporary solution that works for me…

If your Vive headset does not work in MS FlightSim 2020, (the Vive headset display is 95% covered by black circles), then opening the OpenVR Advanced Settings module fixes it for me.

Step 1) Install the third party OpenVR Advanced Settings module for the Vive Cosmos Elite.
Step 2) Run the module. Just running it (starting it) seems to fix the headset problem.



DOWNLOAD: “AdvancedSettings-5.3.1-Installer.exe” file for Windows 10.

From there I can get more access to resetting many OpenVR options. When running the Vive control panel, there is a new ‘Advanced Settings’ circle icon/button in the bottom left (the 3rd icon along from the left)

The result is that the Vive Cosmic Elite headset is working again. After a few plays of FlightSim the Vive headset is 95% filled with black circles again. But, by running the OpenVR Advanced Settings module again, the problem is ‘fixed’ again. Better than broken all of the time.

MS FlightSim appears to scramble some headset view settings (not simply a headset reset/default position issue) and the Advanced Settings module resets something for me.

See also this post in the Bug area from lowdowndan:

This worked also for me.