I7 10700K + 3090 RTX + 32 GB ram = 10 fps on menu / HP Reverb G2

So I just got my brand new computer, with an i7 10700K, an NVidia 3090 RTX and 32 GB of ram. All drivers installed.

I can’t seem to get any decent framerate in Flight Sim. It starts well in 2D, but the second I switch to VR I get about 10 fps (using OpenXR frame stats) even on the main menu. Even worse, if I switch back to 2D, it stays at 10 fps, even on the menu, and at this point 2D or VR it won’t recover.

Task manager shows that CPU is running at about 10% and GPU at about 7%, which given my specs is more or less what I’m expecting.

Tried changing various settings, even reducing the render scale to 30%, no can do. Still 10 fps on menu and sluggish as hell. In game it’s not much better, with reprojection on it kindda helps in exterior view but the cockpit’s basically unplayable.

Any ideas ?

The sim introduced some strange behaviors with the latest updates.

Switching between VR and 2D takes much more time than before (up to minutes to fully restore 2D) and also leaving the sim to the desktop freezes the sim when you are to quick. The same happens when leaving VR to the main menue. The only solution for now is patience.

Surprizingly switching from 2D to VR seems to work like before!?

Something new is working strange in the background I think. We will learn about that soon when more simmers get into this behavoirs.

Anyway, with your hardware, you should get about 30fps easily in non PG areas. Try to start there and not in London city with PG on. Start with low setting in the game (dont touch OpenXR) and work yourself up to an comfortable compromise.

I am running an 8700k with 3090 RTX and started with 32 gb ram. I can get OXR 70, TAA 100 and most settings to ULTRA, in VR on the G2 at playable frame rates even over London (45fps average, 25-30 over London).
There is certainly something wrong. Some people are having trouble with the latest nvidia drivers and the say that DDU’ing and rolling back to 457.30 does the trick. It did not change anything for me, but it might work for you

I’ll try the driver rollback trick. There was a new one recently and since it’s a brand new pc, I went directly with the latest.

My poor 10 fps framerate happens even on the menu, so it’s definitely not related to how “busy” an area is. I also tested in various regions, some deserted, and yeah, no setting or option helps. Everything low and 30% render scale = still poor framerate.

Search on here and you will see a few large/long posts where others have done a lot of trial/error to get settings optimized given how new VR is for MSFS. There are a number of settings to disable that can cause the problems you are seeing (from nvidia control panel settings, to OXR settings for the reverb g2, to in-game settings and even a hidden setting in MSFS (the .exe file itself). The longer posts show all of this from folks that spend tons of time getting it to work and I agree with the above that you should easily see 30fps with that setup. Also, see YouTube where VR Flight Sim Guy and also Overkill have videos detaiing their settings for VR on the HP Reverb G2 with the 3090 and you can copy those directly to try that out. Another helpful and long post here is from CptLucky8 (post is My 2070 Super VR settings); My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR)

1 Like

Follow these steps:
1 - Turn on headset
2 - Shut down the Mixed Reality Portal window
3 - Start MSFS 2020
4 - As soon as in the Airport start VR mode (CTRL/TAB)

OpenXr Custom Render Scale: 100
VR Settings FS2020:
Render Settings: 70
Terrain Level of Detail; 100

Thanks for the feedback everybody. It seems like I’ve made some good progress. What seemed to work is CAP537268’s suggestion. I needed to defer launching WMR until I was already in game ( or was that a lucky shot ? I’ve been playing for an hour now ).

I’m now getting about 30 fps at 100% render scale and a mix of medium and high settings, and go up to 40-45 fps at 70% render scale, which this time is definitely playable. I got around 35 fps over the busy areas like New York.

not a lucky shot…
it works all the time.
Tested 100%.

1 Like

I never got what is meant with ‘shut down the Mixed Reality Portal window’: if you shut it down the headset shuts down doesn’t it? And then when you CTRL/TAB in game basically the Mixed Reality Portal opens again, just in the background?

as soon as you power on the G2, Mixed Reality Portal “window” automatically starts.
Closing this window, G2 still remains in stand-by.
After launching FS20, CTRL-TAB does the job… and you’r done.
The portal obviousely starts again, but with no effects…

1 Like

Cool, ok, I’ll try that . I think that recently that’s the only way I’ve been doing things and indeed I feel I am flying pretty smoothly!

Tried this and my mouse is not active in VR. I have to Ctrl-tab put and back again in ve defying the purpose - and get micro stutter.
If I open wmd without putting on the headset, then launch msfs, then on the runway ctrl-tab into ve and put on the headset that’s when I get best fps and least microstutter

don’t use Full Screen and it will be much easier …

Yes, I am using windowed on PC. every time I plug in the headset - Close WMD, run MSFS windowed, Ctrl-Tab on the runway the mouse in VR is unresponsive.

I plug in my headset leave WMD alone, run MSFS windowed, Ctrl-Tab on runway, put headset on - all good.

you can also “left mouse CLICK” on the simulator window and mouse pointer will function in VR…

Yea indeed! I know but it just doesn’t work ever if I don’t start wmd before msfs!

It surely works!!!
Follow this procedure ::
1 - Close WMD window.
2 - Run MSFS
4 - WMD window opens up on your monitor (flight visible in double screens)
5 - Left click on it - Wear headset and play with mouse cursor clearly visible and usable.

Thank you for the procedure but I swear that I follow it by the letter and every single time I can’t get the cursor visible and usable in the headset!

when you play in VR
WMD window MUST BE VISIBLE ON YOUR MONITOR. If you minimize this window, Mouse disappears…

Ok, I’ll try that too, maybe I minimised it by mistake.

1 Like