ILS approach on Boeing 747 not always working

The ILS approach is selected in the World Map and the corresponding frequency is seemingly stored in the FMC. The problem is that, when I approach the airport, the LOC and G/S diamonds are not showing up.

I found (or at least I thought) a workaround that consisted in either restarting the flight right after it is loaded or by going to the DEP/ARR page in the FMC and by selecting a random STAR, even though I’m not exactly aware of what it is for. This was generally working, but now at Sidney airport there’s no way to get the ILS guidance.

I didn’t do enough attempts to exclude it’s a problem of that specific airport and I don’t even know if this affects the 747 only, since it’s the aircraft I’ve been mainly flying in these first few days I have this simulator. I also have to admit that I’m very new to aviation in general, but I’m pretty much convinced that what I’m reporting is a bug.

Thanks for your consideration.

I’ve had the same problem with the 747. ILS frequency is loaded along with the flight plan within the MCDU. On final approach, the localiser never appears on the MFD. Tried it in US, UK and AUS. It always fails to appear. Ended up having to do manual landings, and in this beast, that’s not always easy. All planning done within the MSFS World map, Low altidude.

Check that the correct ILS frequency is entered in the FMC. This doesn’t always happen automatically.

today I tried something different. I used Simbrief to create a flight plan - Hamberg to Berlin. I entered the FP route manually into the FMC and, hey presto! ILS appeared. Next time though, I’ll do as you suggest and check the ILS frequency is correct.