ILS Approach Waypoint runaround

It’s been worse than before for me. I’d been flying the steam gauge 172 and Mooney since the patch, so hadn’t really noticed it till now.

Since last night, all flights I’ve done with a G1000 or G3000 plane fail when I activate an approach.
Either:

  • I get sent back to my original destination
  • a bunch of blank waypoints get added to my FPL and the plane doesn’t know what to do
  • my MFD freezes or crashes completely, preventing any more IRF flying for that flight.

Before this “fix” it was annoying, but easy to work around. Now it’s just terribly broken.

BTW, tried both with and without the WT mods and no difference. I can’t do any type of IRF approach.

Guess I’ll have to stick with GNS530 planes with the amazing GNS mod and wait to see what the WT team come up with when they release their completely revamped Garmin mods… If I wait for Asobo to fix this, I’ll be waiting a LONG time.

2 Likes

I’m not sure if they fixed this issue, as I’m still using the previous workaround which seems to still work… and it’s too easy not not keep using… (note this assumes you are not selecting an approach until you are assigned one by ATC). So when you get assigned an approach by ATC like “ILS 14R via GITMO” before you add the approach, add the GITMO waypoint to your flight plan. Then add the approach (via GITMO should be part of the approach). This should prevent the dreaded U-turn to a previous waypoint.

5 Likes

I’m a real instrument rated pilot, did my training with a G1000 too. I have the same issue, it’s not user error, the G1000 just doesn’t act the way it’s supposed to in fs2020. When cleared to a fix if you enter it in in real life and activate it, it will take you directly to the IAF you selected, it doesn’t do this weird round about with user waypoints because that’s not how ATC cleared you…it also completely Jack’s up the procedure turn and will not let you activate further legs on the G1000…idk if it’s a bug or just design choice that they went with to make it simpler for non instrument rated pilots, but either way it is very frustrating when I have an actual IAP pulled up, I’m cleared to an IAF, so I activate the approach and it does like you said either a 180 or just takes me on this roundabout entry instead of letting me go to the waypoint fly the PT and procede inbound. I hope if this is a bug it’ll get fixed or if it was a strange design choice that there is an option to remove it eventually because I’m finding it difficult to feel as immersed when the g1000 doesn’t act the way the real one does and I can’t fly an instrument approach the correct way unless I just stop talking with ATC (it also annoys me how the direct button the d with an arrow through it doesn’t immediately pull up the waypoint you were hovering over in your flight plan like it does in the real thing…makes it annoying especially with how difficult it can be to use the fms knob at times)

1 Like

The most infuriating part is that USED to work like that. And the G1000 didn’t always do the stupid things it does now. It actually used to work correctly at one point, bringing you to the IAF directly (vs the stupid new USR point that might randomly appear back at your departure point now).

At launch, you used to be able to hit the -D> button when hovering over something in the G1000 and it would go direct to it. And when given an approach, it would go directly to the IAF. One of the early patches broke both of those things and they haven’t been arsed to fixed them since.

The GNS530 mod actually fixes both those issues that are found in the stock GNS530 as well, and it apparently operates as the real one should. Not being a pilot, I can’t speak from personal experience, but others speak highly of it and its fidelity to the real thing. I just know it’s a joy to use in the Mooney and C172SP compared to fighting with the G1000.

On a side note, in the coming weeks we should see a new version of the Working Title G1000 mod that’s been completely re-written from the ground up with its own code (rather than being extra functionality over Asobo’s code). I’m pretty sure we’ll see those issues fixed. The WT guys don’t screw around. They do good work.

Those still with issues vote here:

2 Likes

Quote from @OMICO4146
“hope I understand your all problem. Pls for first one important thing, one is Load approach and another is Activating approach. In case you don’t activate approach, your aircraft probably will go to IAF and then turninig around with procedure turn, maybe to infinity. Pls take a look for first to teaching yourself with very simple trainings - t/o from airport with ascend to some altitiude defined for app, set FPL now with start and dest airport, then set required app and activate in close destination from IAF. You can everytime check MFD where you are and no hurry.”

Looking back through this thread, I think this is important. I’ve seen the “ENTER DEST DATA” message that requires input in the Perf Approach page (like pressure, temp, MDH, etc) plus activation of this phase. Please correct me if I’ve misunderstood, but isn’t everyone missing this?

No this is not a simple matter of missing a step or procedure. When you activate approach mode most times it will create a user waypoint and then send you backwards to the start of the approach. The only way to get around it is to either enter approach mode well before the first star waypoint or manually fly the star.

Read the posts in the link I posted for the vote thread and you will see it is not a simple matter of folks not knowing how to do something.

3 Likes

Yeah, this isn’t user error. This is a real issue. For the GNS530 mod, the whole nav system was rewritten, and this issue no longer occurs. I hear it’s the same with the CJ4 now that they have a whole new system written for it.

This is definitely an issue with the stock nav systems.

2 Likes

According to the update of 25 it says the following:
Autopilot no longer flies toward a Waypoint removed from the FlightPlan

So have they fixed it?

I have seen this as well, when there is a change in expected RWY.
Workaround manually set direct the aircraft in using the heading mode. Make sure you obey the contraints for the approach. Once the aircraft is lined up with the approach, active the approach mode as this will override the waypoints in the flightplan and follow the glideslope down.

You see what happend in my video at app 33:55

I had the manually control the heading and altitude into the approach.

I think this bug is still active. I flew into KBTV ILS runway 15 yesterday and it only has one approach option, HERRO. It sets a flight path to fly away from the runway, twist around and come back. This happens no matter what departure airport I set, and doesn’t matter if I set it in the world map or in game. You can see this for yourself by setting ILS 15 in the world map for KBTV

when i fly with automatic Approach an ILS Flight and ATC gives me the Approach, then i program it into g1000 and load the plane turns and wants to go back 44 miles := still not fixed

Get the G1000Nxi. It serves a the prototype to replace the buggy Asobo flight planner / AP which causes the kind of bugs you observed.

Further alternatives are the FBW A32NX experimental version and I think the CJ4 from Aerosoft. All have rewritten the underlying flight planner.

1 Like

thanks ok i get the NXi, its beta so i hope there are no gamebreaking bugs like in the Asobo g1000.

There might be … that’s why it is called Beta. See the release notes in the G1000Nxi thread here.

1 Like

ATC and route planning are buggy to say the least. In World Map, usually I start cold and dark, after setting up and IFR flight plan, with a dedicated approach and pick the ILS Landing Runway. Half the time when 10 miles from Runway and touchdown, ATC tells me to ascend to FL18 and completely screws up my landing approach, this after using the very tools built into SIM, and updating the FMC to make sure all my stuff is in it. I have worked out long and detailed “Cold and Dark for 747” and have not successfully been able to land yet except once. Either the Sim has not got clue on airport, redirects me to different altitude in final minutes, or the AP or Auto Throttle is messing up my approach/landing speed or something. YES, this is a complex process, making sure all the correct data is in the FMC has more bearing on success than the AP settings, since they work in harmony, with the FMC taking over most of the chores. It’s also a steep learning curve, of which real pilots do daily more than once, they earn their salary period. I will get it, but it’s a work in progress, and have been sim user since FS-98, part of the problem is the buggy sim, and part is this one is more lifelike than any previous sim, well maybe Xp-10, but I have not used it. I have successfully used FSX and flown all C-17; 747; 737; all over world without too many issues, but this one whoa-back, nothing but issues with it, and no I did not just get incredibly stupid, this thing needs a whole lot of work so it’s “as real as it gets” without all the other junk they throw into it.

I think the only workaround for this is planning the approach already in the sim’s flight planner. That way when you file the IFR plan to get the clearance from delivery the whole trip is planned and cleared. That of course is not very realistic and this bug needs to be fixed. But like that the flights are more enjoyable without the hassle with the on-board computer during the arrival.

I recommend people vote on comment on the official bug report thread that already has over 500 votes.

Approach flyback bug - Not fixed as stated in SU5 - Bugs & Issues / ATC & NAVAIDs - Microsoft Flight Simulator Forums

Also should this topic be merged into that one?

2 Likes

Voted. Already forgot this was supposed to have been fixed in SU5.