Import Blender Model too Difficult

Am I the only person having trouble importing Blender models? At this point, I have created a simple cube with a material on it. I believe I have checked all the right boxes in Blender Export and typed the right letters into the textboxes in Blender Export.

There are many videos I have watched where you then have to rename files and copy and paste guid’s. Why do you have to do that? I have done it though.

There are so many errors in the console window, even in the tutorials. Which ones can you ignore? Which ones should you not ignore?

It seems like one of the keys is that certain files and folders have to be named the same. Sometimes I will clean, rebuild, open and for some reason the sdk console will tell me that it can’t find an XML file with the letters in all caps. It was not like that to begin with. So I go rename the file where it uses all caps. Then clean, rebuild, and open again.

It’s very frustrating. Can someone please point me to an easy to understand tutorial? Or share your tips and tricks?

Thanks.

Hi

It can be a very long and frustrating learning curve to get it to work. But once it works it’s great. Have spent many hours on Youtube etc before I got it right.

First important thing when exporting from Blender is to stay in Object mode and select all items (A) then export and set the right options. Once exported to a folder within the scenery structure make sure that it exports 3 files like this

I also get some errors when building the package. Some are okay but some regarding the model you will use is important. Most of the errors seems to be if all the fields in the scenery box is left empty.

I have also done a video but it’s in Danish so perhaps limited help, but it show the process i’m using. Let me know if I can help further

Regards
Claus

Thank you Claus. I have not ensured that I selected all objects and I have not made sure that I am in Object mode prior to exporting. Thanks for the tips. I will also check out your video.

i wish i spoke Dutch this looks like a well informed video

Google for Flying Theston. He has English videos that bring you to the end of your project, shows most things one needs to know in the 2 playlists.

I just tried following the german tutorial below since in their docs there is not a single A-Z tutorial on how to do it. Problem is, their SDK kit is not the same anymore layout wise, so it deviates from the tutorial. I managed to get my cube into the scene and move it around, yet I am still not exactly sure how. There are artproj and whatnot. I mean I jusrt want to load my obj file, place it and press ‘Package’. How is this so difficult? Then something broke and I could not do it again. A total mess, the most user unfriendly thing.

Then I saw their SDK stream. They basically said they hire people and will now work properly on it. I will be back in a year. I mean just put a warning in front like " do not touch just yet, you will live a total nightmare because we basically only had 2 interns working on it so far". Right now, this thing is a complete disaster to use. I accidently stretched a window to fullscreen. It took me close to 5mins to figure out how to get it back to normal size again. It completely deviates from any 3D software in terms on usage, which makes it really hard. On top, they do not show a single from A-Z example and all infos are scattered across the doc. This was traumatizing to use. I spent 3h, could not get a community folder ready result. I have been doing 3D for 15 years. I must say, no wonder this SDK forum is a wasteland. They need to get this SDK similiar to what people are used to (Blender, 3DS, Unreal, Unity,…).

You just need as a result a “.bin” - “.gltf” and “.xml” file as export from the export Blender addon. You don’t have to have the objects selected, you can be in any mode you want - object or edit-mode , doesn’t matter.
What’s important is, that you tick the creation of a unique GUID numlber (very important) and that the names of the 3 files are equal (the ones with .gltf - .bin - .xml file format extensions).

The next thing you have to watch out is, that you only use textures with sizes based on the hexadecimal system, meaning just use image sizes, that can be perfectly divided by 16 - like 1024x512 - 256x128 … and so on. If you use textures with odd numbers not dividable by 16, then either no texture will show up or the object possibly will not load.

So:

  • missing XML-file (which has the info about the unique GUID number) - won’t work.
  • no unique or right formatted GUID - won’t work.
  • textures with pixel-sizes not dividable by 16 - won’t work.

Easiest way is to use the SDK sample folders - like “SimpleScenery” and your good to go for the first start, because all the necessary files are in there and all the right connected path infos are already set up in there. You need to put your stuff into the “PackageSources” folder for a start.

And - there are many times some errors showing up in the Console window - and still it can or will work. Not everything is related to something, that will stop it from working.

Are you sure texture dimensions must be multiples of 16, and not powers of 2 instead?

In my optimization tools, i ensure that the baked textures produced are a multiple of 4. It is an hexa system, but in two dimensions, so the width and the height must be a multiple of 4.

1 Like

Yes, the bin/gltf/xml files are understood. This is what the video about too. That’s the easy part in Blender.
But then I go ahead with the SDK, and the newest version deviates from any tutorial. Even their own samples are different from what is shown in their docs (Simplescenery is not a cube anymore).

They just need to do the A-Z examples. Right now, they wrote the docs as a reminder for them how things work. I know how this works, I am developing/writing docs myself. They need to write it for people who do not know about the SDK. Proper introduction, go by example and so on. This ‘collection of developer notes’ right now is not a documentation.

No doubt, TheLittlePilot1, i have to agree - the SDK documentation isn’t really written for anyone. It’s written by people, who are working with this system for a long time, so a lot of stuff is for them ‘naturally’ logical …

thalixte - i’m by no means an expert, in my opinion i’m still working on noob level - i’ve just learned the last 5 weeks a few things (i’m pretty new to this stuff, too), while working on my Ramstein Air Base Enhancement, what worked and didn’t work and that i can’t use any pixel size numbered textures - many of the textures used by Asobo are like 1024x1024 or 2048x2048 - so for me it was the easiest way to go for a 16 based number - and from that moment on everything worked, so if values multiple of 4 are working, too, okay, didn’t know that. But basically i wanted to mention, that the texture pixel sizes are important - good to let everyone know, that it works with multiple of 4.
By the way, i’ve used your cleaning up tool on my Heidelberg photo3D scenery, great tools, thx for that.

The posting theme was about import of Blender models being too difficult - and if you look out for a few things, it is not. That the SDK won’t help you in this process using any 3D creation program and their special exporters and how they work, is for sure clear - that doesn’t belong in a SDK - because if you want to create something for MSFS using 3D software like Blender or like Asobo uses 3DSMax, they have to assume, that everyone doing that has at least some basic knowledge of using external 3D software, they can’t teach people in the SDK, how to work with those, that’s too much to ask for. And i believe Asobo doesn’t directly support the use of Blender, they support the use of 3DSMax, that’s why they’ve included the 3DSMax exporter in the SDK.

A few more hints, what to watch out for, yes, they probably could have done that … And there is so much more, that i don’t know, but i believe that to get a Blender model working in MSFS is one of the easiest things to do of all the SDK stuff.
Because a SDK , in my opinion, assumes that people using it already basically know what to do. It’s not suppose to be a tutorial for total beginners in this field, it’s a information tool mainly for “developers” - and that should be people with some experience in different areas. If someone wants to learn how to use any software for developement, they have to look for special tutorials on the internet, text or video …

textures definitely need factor of 2. It is called ‘power of two’ and enables mip-mapping. It is a standard feature in DirectX. It is pretty much the same in any SDK that uses DirectX/OpenGL, may it be Unity3D, Unreal, CryEngine, or here the Flight Simulator.

I tried again this morning. Simple cube from Blender with the gltf exporter. All there, gltf/xml/bin. Did it by the book, all paths seem ok. 209 Erros, did not work. Honestly, this the poorest SDK I have ever seen. Even their installer does not have a author. Author is unknown so Windows blocks it unless you permit exception. Where did they find the guy who developed this thing of an SDK?

1 Like

Have you tried to view your gltf objects using the Windows 10 build in 3D viewer ? It will show, if your object is working basically. It’s a first test, that your object is a working gltf.
Like here - displaying my finished Tower building:

But the 3D viewer is more forgiving then MSFS and it’s object rules. The 3D viewer doesn’t care about the pixel size of textures, so it will show the object anyway. And it doesn’t need the XML file with the unique GUID number. But you have to make sure, that the gltf and bin files are together in the same folder, so that this 3D viewer can find it. In MSFS the textures are suppose to be separated from the the three object files - so there has to be a “tower” folder containing gltf, bin, xml and a texture folder containing the textures.
And if you put those two folders into the “modellib” folder, which is placed in the “PackageSources” folder, then you should be ready to go.

This 3D viewer is a first test outside of MSFS, if you did something right. From there it is mostly only a matter of texture pixel size and xml with a unique GUID number - then it should work in the sim, too.

These are the exporter settings i use:

You just have to use the SimpleScenery example like it’s stored in the SDK folder. Just drop those two folders -the folder with the three exported object files - and the texture folder - into the “modellib” folder in this SimpleScenery folder example - and you are ready to go.

One more thing i have to add … there was some odd, weird behaviour with the Blender exporter. Sometimes the objects didn’t show up as working, like in this 3D viewer image above, only a rotating cube symbol was shown, so it meant, that the object wasn’t working.
All i did, i’ve tried to export with a different name and then, nothing changing, the object showed up.
Example:
I called the export object like “hercules1.gltf” - exported object seemed to be wrong, not working, even in the Windows 3D viewer. Then i renamed it “hercules0.gltf” - and like a miracle, it worked without changes. Renamed it “hercules2.gltf” - it worked. Renamed it again “hercules1.gltf” - it didn’t work. I had to do name changes quite a few times. But all the time, an object didn’t seem to work, i’ve tried this renaming and of a sudden most of them did work.
I don’t know, if this is a problem with the exporter, or if it is just a problem on my side, but still it’s worth a try, if something isn’t working. I can’t explain it, but that way i got rid of a lot of problems.

Weird …

yes, everything up to the 3D model is fine. Shows in 3D viewer, guid checked, xml there. All no problem.
Just the SDK does not wok. I will just wait a few months. In their last live stream they basically said straight away that up to this point they only had 1 1/2 interns working on this and are now hiring more people. Waste of time digging through that mess at this point.