Impossible to smoothly control aircraft with Yoke/joystick

I am now 100% sure my problem as described above is my Saitek Pro yoke, (white noise). I swopped it for an old Logitech Freedom 2.4 joystick of mine and with sensitivity at -70% and dead zone at 5% I control the aircraft smoothly. What is strange is that the yoke work perfectIy in FSX. Will check if I can repair it.

Thanks for all the assistance and advice.

I followed your advice and opened the yoke and clean the pots with cleaner and it solved the “noise”. I also did the rubber band mod and the yoke is 100% better. I can use it now again and make small inputs that I could not have done before the cleaning.

Thanks, I appreciate.

1 Like

I have the hotties x 52 and find it hard to take off as rudder on the twist on joystick is so sensitive it’s unresponsive sometimes like it lags in response tried everything to sort I just gave up

how do u do this ?
sensitivity at -70% and dead zone at 5%

Thank you! This was EXACTLY the mistake I was making! Followed your direction, plus adjusted sensitivity and dead zone as others have suggested, and now my X-55 Hotas is finally functional!

This is the correct solution…

On the controller settings page there is a large button in the upper left corner of the window labeled “Sensitivity.” Click this :sunglasses:

1 Like

Controls menu, on the left side there the sensitivity menu.

1 Like

The issue is that they use the same XBox thumbstick logic for joysticks and yokes.

Anything more than 25% input on any axis gets increased gets increased to the point where it just becomes on/off unless you use -70% then all fine control is lost unless you go over 25% but at least its controllable.

Spot on. Especially on CH products

:+1: :+1: