Impossible to smoothly control aircraft with Yoke/joystick

I have used my Saitek Pro yoke and a Logitech joy stick (separately) and find it almost impossible to control any aircraft smoothly. It is if there is a lag for a second after an input and then a “violent” reaction will follow. There is nothing wrong with the controllers as they perform 100% in FSX. Tried various sensitivity settings with no avail. Anyone else experiencing the same, and/or advice.


My Logitech Extreme controller had this similar issue. I found at dead centre, it was a little touchy because of the sensors, and the rudder in specifically would just throw the aircraft around like crazy!

What I did to fix this was increase the dead/null zone in the joystick settings. It displays a graph with the input of the controls as you adjust it, so you can finely tune the dead zone to your liking. This will mean you’ll have to input more joystick movement until the control surface reacts, but it will solve the touchy-ness problem! At least it worked for me :slight_smile:

Put in about 5% deadzone and about -50% sensitivity (or less, like -75%).


I second this. Even if I hate the dead zone (and tend to not really use it) a few percent will fix a lot. Also, I’m setting sensitivity to about -60%. Without these settings at least the smaller prop planes are a nightmare to fly.

1 Like

cant get the flight controllers they suggested I should buy to work on this thing. Game wont even recognize them so whats the point then. going back to x plane 11 as well.

1 Like

I’m using my 15-year old CH yoke and pedals with the above deadzone and sensitivity settings. Both work great.

@ cowygr8
I concur, I use just a joystick ATM and I had problems with twitchy controls. Then I adjusted the NULL zone and Sensitivity several times until I got it will work much smoother and this makes the aircraft far more stable.
Now if only I can get my Logitech Flight Controllers to work, all would be sweet…

Why cant you get your other controllers to work?? What is the issue…not detected?

Click on the magnifying glass at the top right of these forums and type Control Setup - Quick tip

I have tried a number of setting with an Ms Force feedback 2 and a Cessna seems impossible to fly. I will try ramping up the sensitivity further but not hopeful.

Have you assigned your roll and pitch to an Axis??

Roll Pitch and rudder all assigned.

To an axis, not a button press?

Look this up on youtube - Tutorial #2 - Peripheral Control Setup - Microsoft Flight Simulator

Yes all on the X y Z axis. and validated through settings

As I stated above, the Youtube tutorial is worth it

Thanks for the advice so far. I have tried various sensitivity settings and can not get it smooth though, specially on final approach. Perhaps my problem is the Saitek yoke itself, there appears to be a lot of “noise” (I can see little vibrations on the sensitivity screen).

The Saitek yokes use pots which get ■■■■■ over time. The only way you can resolve noise is either replace the pot or try and clean it with some electrical contact cleaner.

Sorry but if you can see noise then the above is about all you can do short of replacing the yoke

I’ve tried the sensitivity and null zones with mixed results… But the one biting me is the elevator trim. The very slightest touch sends the aircraft zooming in a climb or descent. The other thing is the aircraft seems to love to roll left.

So I had this problem with the rudder pedals (either on or off). I thought I had selected the Axis bidning, but thanks to a post from another user here on closer inspection I had selected the Rudder L and Rudder R axis, as opposed to Rudder Axis. An easy oversight, and not exactly obvious. But the impact is that the former treats the message as a keyswitch on or off, while the latter gives you the full range of input. I deleted my bindings in then made a single selection to bind the rudder to Rudder Axis. All of that sounds more confusing than it actually was in practice, but setting the sensitivity down to -57% I now have pedals that behave exactly how they should.

Thanks, I will see what I can do about the noise as I more and more suspect that is my issue here.

When configuring axis there is a very easy mistake to do. For instance there is three options for elevator: Elevator up, Elevator down and Elevator Axis. Make sure to place the axis in the axis option, and not in the up or down. The same goes for ailerons and rudder. The first to are intended for buttons.

1 Like