Inconsistent performance (Quest 2)

It’s a bit frustrating. It often happens to me that I have great smooth VR sessions turning into a nightmare after Switching to PC mode and back. Also, one day the game seems to run fine and the other day it’s completely unplayable with the same settings. Any reasons why this could be the case?


I find the Oculus link software to be less than stellar. Most times I need to start the app and switch to VR more than once in order to get good visual clarity in the cockpit. And once I do get good clarity I need OTT to stabilize the image. I have the Oculus app set at 80hz and 1.1x (4224x2128) and OTT set at 1.6SS, ASW and adaptive GPU scaling off and FOV mulitplier at 95,95.

One thing I never do is try to switch back and forth between VR and 2D - that never ends well (for me). You could consider trying Virtual Desktop instead of link but you’ll need a good 5G or wifi6 wifi router that is dedicated to your headset. I have not tried that but won’t rule it out.

Hope this helps and good luck.

EDIT: Not that anyone should copy another users settings as each system is different but I just corrected the render resolution settings that I use in the Oculus app.

1 Like

I have noticed that with strange behavior with frequent frames, when they drop or start floating. Switching ASW back and forth helps. For example I usually use Force 45fps, asw disabled and if problems start I switch asw to disabled then switch Force 45fps, asw disabled again and the frame rate normalizes.

Yes. This. All the time. I have a reverb g2 not a quest but yes. Somedays worse than others. Nothing else changes.

I’m curious to see if we see worse / better performance on the same days.

I5 9600k 5ghz
32gb ram
2070 super

Same here! I literally opened this forum today to find if someone else is having this issue. Yesterday I started the game, selected Spitfire Mk IX and Biggin Hill as a departure. The game was unplayable in VR. FPS were below 30 or ASW didn’t kick in (I use Reverb G2). I closed the game completely, started it again in the same location and same plane and this time everything was smooth as butter. It’s not the first time I experienced this but yesterday was the most recent one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.