Infinite Battery (and I don't want it)

I appear to have infinite battery in every airplane. The load is there but the voltage never goes down.

I’ve found no settings that do this. I have gone into Assistance and reset the settings and then set everything to hard.

If I set in the airplane without GPU and without engines the battery doesn’t deplete. I’ve tried without dev mode but other developers are seeing the battery drain as well.

I can’t think of any setting or any way I could have got into this state. Does anyone have any ideas?

1 Like

might be plane specific? not sure. I know for instance on the C172 if you leave the starter on you’ll drain the battery, and the displays etc will start flickering.

It’s specifically not plane specific and not the planes. Others are seeing the battery drain in the same aircraft.

If I jump into the C172 dark and power up, turn on the lights and pitot, the battery doesn’t drain even with load:

any assists active? Set everything in that menu to hard maybe. Also make sure you don’t have any copilot controls active.
Also maybe doublecheck you’re on the modern flight model. Who knows.

Did the assists, reset all and then set to hard. Made no difference.

AI controls is off.

I’ll double check the flight model, that could make a lot of sense.

Yeah flight model was already modern.

I think the FBW team has the electrical systems simulated in their latest release for the A32NX mod for the A320 which includes variable battery voltages…

If you watch one of the earlier episodes of the official twitch channel flying lessons, they forgot to turn on the alternator in the c172 and at some point the radio stack had no more power. So I think the battery drains, but maybe it does not show the actual draining.

I forgot to turn on the alternator on one of my first flights with the new JF PA28.
After two thirds of my pattern flown, i was not able to lower the gear.
Even switching the alternator on then didnt fix this and i had to go around, consult the manual and use the emergency gear drop handle. All this in marginal VFR conditions…great experience it was.
So at least in the JF PA they simulate it correctly :slight_smile: :+1:

I’ve verified the position of all the the stuff in [ELECTRICAL]. The battery is loaded but the voltage doesn’t go down. Others using the same aircraft files have battery drain, it’s not about configuration of the plane. Every plane I get in has infinite power from only the main battery. GPU is not connected. gen/alts are off.

are you using the ‘developer mode’ ?
You are the guy working on the H135 flight model right? nice work BtW…
I think the ‘developer mode’ in MSFS has some quirky affects and this could be one…

I’m in dev mode but I turned that off and restarted the sim, deployed the airplane package only to Community folder etc. But other people are using dev mode and having battery drain. I actually have a lot of external SimConnect stuff monitoring this stuff so I’m 100% sure my batteries used to drain in C172 and Longitude (and all the others). I’ve also tried resetting my sim settings but the cloud sync stuff hampers that.

Yes I’m behind the H135 flight mechanics, thanks for the kind words. I’ve had a lot of help.

1 Like

no worries - having a functioning and fun helicopter at this stage of MSFS is a huge windfall for us rotor heads.
Sorry this problem is persistent. It just HAS to be a setting though - right? There’s no other way for the issue to be local to your machine otherwise - one would think.
I hope you can discover it or that someone with an answer will chime in soon

I have a feeling you’ll have more luck finding an answer by moving your topic to this subsection:

[Latest Bugs & Issues/SDK topics - Microsoft Flight Simulator Forums] Latest SDK Discussion topics - Microsoft Flight Simulator Forums

There’s no reason to believe this is an SDK issue. Again, I have no battery drain in the default C172 with nothing in the Community folder.

not saying it’s an SDK issue. Just saying that the people who frequent that forum subsection generally have more in-depth knowledge of the inner workings of the sim, and might be able to help you out faster than posting in the General section :slight_smile:

1 Like

I do believe I have some persisted data. I tried full sim reinstall (but with copying the Packages folder so I didn’t need to do the 140GB again) and it downloaded the cloud data. It’s not clear to me if there is any facility to actually reset the cloud data for those that got the game from the Windows Store. Some have suggested starting the game without internet but that fails because XBL pops up and then it puts you through the “press any key” loop.

With Steam there is a cloud data cache that can be cleared, but the Windows Store version is unpopular and the only suggestion is the “app reset” which doesn’t reset cloud data.

yeah - I bought from MS directly too, thinking I didn’t want any Steam issues to come between me and my flight sim. Figuring that Steam would just add an extra layer of problems overall, should any arise.
Who knew the opposite could be true…
It sounds like your assessment is not just plausible but likely at this point.
Zendesk is four letter word but maybe they can say whether your cloud data can be reset? deleted prior to reinstallation? amputated and cauterized?

1 Like

Good idea. I’ve yet to submit a zendesk issue and this might be exactly the right avenue.

Edit: I’ve submitted a ticket, will see how this goes.

1 Like

Here’s the reply I got. suspect this is the end.

We have re-qualified this ticket into a bug report. Our team of experts will review the information you provided to categorize and prioritize the issue. Please be aware that, while we review each report manually, we are unable to provide an individual update, unless our experts require more information.