Install stuck on Preparing 0%


Are you on Steam or Microsoft Store version?

Microsoft Store

Are you using Developer Mode or made changes in it?


Brief description of the issue:

Sim Update 6 wasn’t downloading, so I tried to uninstall and reinstall. Now Xbox app is stuck on “Preparing 0%” with no sign of progress and no CPU / Network usage.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

Open Windows 11 Store → Look for Flight Simulator → Get redirected to Xbox app → Install from Xbox app → Installation is stuck at Preparing 0% for hours.

PC specs and/or peripheral set up of relevant:

Windows 11
1Gbps Fiber connection

Build Version # when you first started experiencing this issue:


I am still completely blocked on this. Now it’s stuck on resuming 0%.

I am not sure if the issue is related to me owning both the Premium Deluxe edition and having the Standard version through GamePass. Really eager to try out Sim Update 6 but not sure what else I could do beyond the nuclear option of reinstalling Windows.

I have tried repairing, resetting gaming services and the xbox app, but have had no luck so far.

Hi, i have the same issue. Did you somehow get to fix that issue?

Any joy with this? I am having the same issue.

I ended up having to reinstall Windows to fix the issue the last time around. This is now happening again with the new update, and I am beyond frustrated :frowning:

This was never an issue when the updates were handled by the Microsoft Store app. Now with the Xbox app involved, it’s been a train wreck.

I can’t keep reinstalling Windows to overcome this bug since setting everything up again is way too much work. The only workaround I see if to buy the game on Steam, but that seems like a poor workaround given the cost and inconvenience involved.

1 Like

Thankfully, I was able to recover the install this time around. While the update looks stuck, it does eventually start (I didn’t make the mistake of uninstalling the game like last time).

I am having nearly the same problem for the last few days. On clicking ‘OK’ when the sim says there is a mandatory update, I am taken to a Microsoft Store page that does not give me the option of selecting an upgrade. MSFS is stuck on this page, but nothing happens. I have let it run this way for about 1/2 hour several times since the afternoon of 11/18, but no update is happening. Any suggestions?

1 Like

One more item concerning getting stuck on a page in the Microsoft Store, I just tried to install the update again. This time I opened Task Manager after I started the update. Initially, MS Flight Simulator shows up in Task Manager. However, as soon as I clicked ‘OK’ to start the update, MS Flight Simulator disappears in Task Manager. So, it appears that whatever page I am being sent to shuts down the update! Thanks for any suggestions that anyone can give me.

Anyone find a fix for this? I am stuck on ‘preparing 0%’

I am stuck on this as well after trying to update to SU8 beta. I got redirected to the xbox app to install the update, but it froze at ‘preparing 0%’. I thought I could fix this by opting out, but the update download was still there frozen in the download cue at 0%, and hitting cancel wouldn’t work, so I figured uninstalling/reinstalling would fix this. I was wrong, and now when I go to do a fresh install on the xbox app, it freezes at ‘preparing 0%’ again! I tried repairing, resetting, and finally uninstalling/reinstalling the app, but each time I’d come back, the SU8 beta update would appear in the download cue stuck at 'preparing 0%. I guess the beta download won’t clear from the xbox app, and now I can’t even reinstall the non-beta version that I ended up purchasing through the xbox app. It just gets stuck at ‘preparing 0%’… I’ve scoured the internet and tried all of the suggested solutions except for reinstalling Windows 11 (which I do NOT want to do), and none of them work… how a $90 product can have an issue this bad is just beyond me… PLEASE HELP!

I have the same problem after doing a clean install of win 11, i get to install the first portion of the game (1.2GB) and then when i start it it wants to update ~120GB but i only get to ~ 600MB before it stops on a decompressing of a file. so i went and tried to decompress with 7-zip and found that there was alot of CRC errors in the file, it´s always WAV files that are corrupt.

After i did that i closed the installation of MSFS and ran it again, i got a bit further this time so i did the step above like 10-15 times. I tried to install on diffrent SSD´s but same problem
The i thougt it might be win 11 so i did a fresh install of win 10 did all the updates but the same problem accours again, even tryed with diffrent VPN locations in the US to try to get another installation server if there was the EU servers but same files have the same problem… So now i dont have a clue what to do.

I have the Microsoft Flight Simulator: Deluxe Game of the Year Edition
PC is CPU 3950X , 3080 GPU, RAM 32gb

decompressing errors

I have this problem. Has anyone managed to solve it yet?

I solved the problem… for me at least. To clarify, I’m on a wifi connection. Make sure to disable IPv6 in your router’s network settings. After that, if you have any issues with updating through the Xbox app or wherever you update from, just disconnect your computer from your wifi network, and then reconnect and make another attempt to update your sim. It’s beyond me how microsoft can be lazy enough to allow an issue this small to completely block the user’s ability to update a new sim that costs $90, but I guess that’s big tech in a nutshell. Oh well. Hope this helps.

Anybody got any more ideas for Windows 11 networked connection please? I get this on my brand new shiny (for n replace with tt) Windows 11 machine plugged into a network. When there is an update, even a small one, it goes crazy: stall at 0%, you cancel, try to disable the firewall, restart try again , restart try again , restart try again, then it decides that it has uninstalled the entire package and you are left with it trying to download a small update AND the entire 123GB from scratch. But wait, after an hour it has managed to download 16Kb, maybe it will have downloaded by the time Windows 12 is out?
PS. I NEVER had any problems like this on my old Windows 10 machine.

1 Like

Alright so I battled this on two computers over the last SU9. Before I even attempted the very quick update I had made sure all other updates were done and drivers installed, nonetheless somehow I jacked it up.

Now to the point on preparing 0% stuck. I had this for several hours on both computers. My newer computer finally went through on its own. Total install took an afternoon and whole night.

The older computer was stuck at preparing and I gave up for the day. Then came back tonight and did every trick in the book - wsreset, reinstall the Xbox App Store reinstall gaming services turn off firewalls, disable ivp6, reset repair etc. none of that appeared to work. Then I started the download again and it was in a similar state. I was ready to give up, closed the Xbox app (so that it went into the bottom right tray), then sat there thinking if I wanted to play on the internet before I shut down. I opened up the Xbox app again and BAM the download was at 99% compete. I actually did this about two more times where I minimized to the system tray and then it pushed the download through! I am now installing the full 123GB.

Odd as it is, I hope this helps, or at least gives you some hope even after you’ve tried all other options out there.

Sometimes the Xbox app reminds of a crazy uncle, or of dove hunting.

Alrighty so, i had the same issue and after reading through some other similar issue and troubleshooting i tried to download it via microsoft store. I know that it downloads through xbox but i didnt get the issue anymore. Alright this message was a bit of a mess but my steps were

-Deleting Xbox
Going on MS Store
-Search up flight sim
-Press download via xbox when the Xbox app is still deleted
It will download the fresh xbox app and instantly download MS Flight Sim and the download is still going

Ill give an update on wether the game works

It worked, its ingame download now