Installation Different Drive


Microsoft Store

So I am trying to install MSFS onto my A drive as my C drive is intended for OS and Programs (not games). Yesterday I began installing MSFS and I selected my A drive when starting off. I had to turn my PC off late at night after it downloading literally ALL day with about 8GB left to download. Today I have returned to continue and it is saying I have to download it all again. I have even tried changing the path again.

Am I missing something? The files are there from yesterday but don’t seem to be registering on the installer. I am not even going to waste my time downloading this again if I have to and I will be sticking with FSX which actually has a decent installer…

Read this carefully :

I think you have to select the path again, when I install it under different folders. Take care which path is shown, select the correct and it should show the correct size. I have FS data on 2 drives too and have to pay attention where FS asks me to download to

I did everything on that and it didn’t resolve itself. I tried selecting different folders etc. I even tried downloading it again and it just got stuck in an endless loop at decompressing or download.

I have given up and I’m very disappointed, I am just very glad that I was using the game pass and I hadn’t threw my money away. Deleted and removed it all. I will stick to FSX until they decide to pull their finger out and fix MSFS (if they ever do), the hundreds of bad reviews speak for themselves and I will not be wasting any more time.

I’m having the same issue. I’ve had this download loop before. Got game pass to give the sim a try again after a year, installed fine into the default install location. Sim was running great, but I tried to install some liveries and I got the “file name too long error” which is related to the fact that the default install goes into a folder with a massive file name (can you see the level of developer incompetence starting to rear its head here), so I tried to move the folders but because of the administrator lock on the install director it was a hassle, just decided to reinstall to the a new folder on my D: drive with a custom name “MSFS2020” and now I’m in the download loop. I ONLY have ever had the download loop after trying to reinstall the game which leads me to believe it has to do with something residing in the app cache that’s causing the issue. Either way, too much of a hassle to waste precious time on. Sorry Asobo, you lost my full purchase.

Not sure if the part related to “UserCfg.opt” has been read through the previously provided link …