Installation Manager Stuck Decompressing *SOLVED*

6 months ago the sim crashed on me in the middle of a flight. No big deal, that happened from time to time. However, this time, it wouldn’t start again. I decided to uninstall the game entirely and start over. Well I’ve been trying for the last 6 months to accomplish that, never to make it through the installer. Until yesterday. I have read every thread, done everything in my power, refreshed the whole PC, done literally EVERYTHING to no avail. Yesterday I tried something that revealed the problem, a solution I REALLY hope helps others out there AND helps Asobo/Microsoft help others and / or reconfigure their software and/or offer better support on the issue.

The problem: install manager would begin updating / downloading, but become stuck decompressing (a different file every time)

Things I tried: every single thing suggested by zendesk, I tried net limiter, changing folders, pc reset, no firewalls, I mean seriously, a different possible solution every other day for 6 months. I won’t even bother trying to list everything I tried.

My configuration: Steam deluxe edition. LAN direct to router. Ryzen 9 3900x, GTX2070 Super, 32GB DDR43200, 1TB Nvme, MSI x570 gaming plus mobo, windows 10, every single driver and BIOS fully updated, no overclocking.

The solution: I don’t know why I thought of this, but yesterday I ran microsoft memory diagnostic tool. The memory test failed. I pulled one of my DIMMs, re-ran the test, it failed again. Swapped the DIMMs, (running one of my 16GB DIMMs), the test passed with no problems. I immediately restarted the SIM, began downloading to a new folder from the beginning, (at full download speed with no netlimiter, download was stable around 14mbps) and voila! 10 hours later, the game is fully downloaded and installed.

Analysis: obviously I had a bad memory card. I’m not a super computer whiz, but logic tells me the card was losing or corrupting data while decompressing large files causing the hang up. The interesting thing is, I use a ton of other large and complex software on my PC and never had any issues, including powerful rendering software. The hardware issue only seemed to present itself with Microsoft flight simulator. I still think this is something they need to look into for this reason, the files that are being decompressed are quite large. The installer should detect and suggest there has been a failure, and this should DEFINITELY be something they suggest when troubleshooting with someone having the same problem.

I never would have thought I had a hardware problem, but I was at my wits end and was willing to try anything. The SIM is back up and running 100% today and I have a memory card on its way to GSkill for warranty replacement.

I hope so so so much this helps someone out there get past this problem. Good luck!!

Most home computers don’t use error correcting ECC RAM and apparently a lot don’t even have parity bits to detect errors. Parity RAM can be fooled, though - double-bit errors (or worse) can fool it if the parity remains the same. If there isn’t a software layer to double check, it doesn’t know what’s wrong or why data doesn’t make sense.

Very glad you found your issue! A great reminder that people may need to run a memory test as they troubleshoot.

I’ve been getting this now for the last 3 months or so. I’ve even tried complete new install’s of the game in different folders each time, but get stuck decompressing.

I was suffering from blue screen of death due to memory management problems, so replaced all 4 of sticks of ram for new one. No bsod so far but the game still gets stuck decompressing.

I have tried deleting the file that gets stuck and re launching the game, it carries on and then gets stuck, delete that file and it carries on until the end. then it starts to go through all those files again 1 at a time and downloads and gets stuck yet again.

This is worse than the game working and ctd just as you touch down for a landing wasting several hours.

I thought I should share my experience and solution regarding getting stuck on decompressing files when updating the game. I´ve had problems with this at least since world update 5 and probably earlier as well. With the recent world update 6 the problem got to the point I couldn’t finish the update. After numerous attempts deleting uncompressed files in the official directory and restarting the update (which has worked before), and tried the solutions I found in a post from the Zendesk, I stumbled over this post and as a last resort ran the windows memory diagnostic tool. It confirmed faulty memory. I was about trying to nail down which sticks were faulty when I came to think of that I had enabled XMP profile 2 in the BIOS (the most aggressive “Overclocking” profile of the two). As I remembered reading somewhere it could lead to unstable performance I turned it off. This time no errors were found when running the memory diagnostic tool and the update went butter smooth. So sum summarum; it might be a good idea to check and disable XMP if you run into problems with faulty memory and files not being decompressed when updating before buying new memory. I hope this will help some of you having this problem!


You are a legend! I went through the exact same thing verbatim. I changed my XMP profile and everything is running smoothly now. Can’t believe I didn’t think of that. :man_facepalming:

1 Like

I’m going to try disabling XMP. I had just turned it on before attempting a fresh download on my new build (windows 11). So I hope that does it. It will always eventually go from “downloading” to “decompressing” and get held up there, hopefully you’re issue is my issue. I’ll report back!!! Thanks for letting us know that the OP solution worked!

Ugh, well, that didn’t fix it, it’s back to decompressing and just stays there for days if I leave it go.This time it says “Decompressing fs-base-0.1.207.fspatch.002 dot dot dot” , and the dots do continue to flash, but the percentage complete gets stuck and it could simply go on forever on that exact file. Such a nightmare. I have found and tried all the Suggested fix steps on multiple locations on this site, no luck. My memory has been cleared to be good , tested a million times, verified by the manufacturer technical support to be setup correctly and yet I still get referenced memory location errors and the ubiquitous error 0xc0000005
, etc.

Topic Author selected solution. Other replies since then may not be solved or be related to original Topic.