Installation stuck at 0%

#PC
#Microsoft Store

I’ve seen various posts with similar issues, but wanted to post mine as nothing I’ve seen in other threads fixes it, and I’m very close to permanently uninstalling which is a shame.

  1. On starting MSFS yesterday it said there is an update available, but when I clicked the link it’d open the Windows Store but there was no update option.
  2. So I solved this by loading the Windows Xbox App, and launching the game from there — update download started
  3. I ran out of time and had to cancel the upload before it had finished
  4. On trying to load MSFS today, the update starts from the beginning, but keeps failing midway through the first file, and so is stuck at 0%

I’ve tried signing in and out of Xbox app, used NetLimiter to restrict download/upload, running MSFS as administrator, completely uninstalled the sim, removed packages, deactivated all anti-virus and Windows defender, and still I have the same problem — stuck at 0% on trying to reinstall the whole sim.

This is so frustrating, it just seems so badly coded, and help or advice much appreciated.

One thing to check is to see if Windows itself has any pending Operating System updates. There’s a dependency there that isn’t well understood, but I’ve seen it in early days of the sim.

1 Like

Yesterday I decided completely reinstall MSFS and stuck with the same problem. I reinstalled MSFS few time before but have never experienced anything like that . My download loops around one file asobo-flight-tutorialls-newlanding-0.1.15.fspackage (in the very beginning.) I haven’t seen anything like that ever. I’ve been with MSFS since alpha!

is signature for the download ‘loop’ problem many instances and versions reported. Happening to me now, and tried another computer here, which does exactly the same, and worse, zeroing the 10th little file downloading,

this is most likely a bug in download install manager, which has an unpack CRC problem in the back traffic, and which is in the connection from the MS servers to the computers, which is an extremely extravagant bug.

Nothing to do with your PC or your router, it’s a beyond horrible.

Dont re-install, i dosent help at all, when trying to install again,you get stucked by the first dwl file (unfortunately happend to me - I have used the whole day trying to resolve :O( So lets hope MS/Asobo get this sorted out SOON

Ah thanks all, slightly reassuring in a way that it’s a bug with the software and not some hidden gremlin on my machine — (mine also gets in the loop on the asobo flight tutorials file). Bit of a bummer that I uninstalled the whole sim because of it, so when/if they fix it, have to completely reinstall for no reason, doh!

I was pulling my hair out this morning trying to troubleshoot this! Glad to hear others have the same problem and it’s not my PC. I subscribed to Game Pass Ultimate yesterday and downloaded FS2020 overnight. I left it running at the installation manager to download the mandatory update and went to sleep. So this morning I saw that it never completed the download and it looks like it is stuck in a loop at 1/335, trying to download asobo-discovery-giza…

1 Like

Yeah, its always the first 3 files.

I hope Asobo fixes it ASAP. I reinstalled MSFS several times before but never had problems like that. It’s a shame year later we still have installation issue :frowning:

man its the same for me… since the last updated its just ruined it all. i removed the entire game and tried to install it again but its stuck at the beginning.

Same for me, how do we raise attention for this so MS looks into it?

Buy not buying their products anymore? Seriously its probably something they need to fix on their end.

1 Like

This is reassuring. I’ve been trying to find the answer to this since I tried to install the game on my brand new computer last night.

The only thing that I have not yet tried is making sure that all of the folders are out of AppData prior to installing. Has anyone else tried that yet? Because I’ve tried literally everything else and come up empty.

Hi everyone,

I now have the same issue.

Firstly I was stuck to download the last World Update (looping after 50mo), so I decided to reinstall the game from scratch.
Now I cannot even start the installation process, it keeps looping and looping from one of the first file
“asobo-aircraft-baron-58-livery” and still at 0%

I’ve raised a Zendesk ticket, and they’ve replied saying they known about it and are working on a fix as we speak. :slight_smile:

3 Likes

Same issue here. Glad to hear it’s not just me! Flight Sim updated the client from the Xbox app yesterday, then upon launching it updated about 16 out of 20gigs of updates, and stalled on the base-sounds one. I tried deleting the last few things, to no avail. Even tried moving the packages folder, nothing. Then moved the packages folder and reinstalled Flight Sim, now it’s stuck on the very first thing (or the same thing if I move the packages folder back).

MS is aware and just made an announcement about it.

[KNOWN ISSUE] Download loops - Community / News and Announcements - Microsoft Flight Simulator Forums

Same here, so frustrating! My new PC and all the hardware waiting for the FS and… this happens. That is unacceptable. I see there’s a message that Asobo is working on it - hopefully they’ll get this fixed anytime soon.
My FS instance got broken by the patch update (Austria/Germany/Switzerland) and ultimately I had to reinstall the whole thing. Left it overnight and ended up with 34Gigs downloaded and a loop… never made it further than couple of gigs later.
That should never happen!

1 Like

FYI: This issue has now been fixed by Microsoft, downloads/installations should now be working normally for everyone.

What did you do if anything that actually overcame the issue - it might help someone else?