Intermittent: All assistance options automatically gets set to easy every time you relaunch the sim or sometimes between flights

I’m experiencing this as well. At first, it would revert every time I would restart, but a few times I got a CTD while working in developer mode and the settings stuck. The next time the settings reverted, I started the sim, set the settings I wanted, shut it down and restarted it again. That time around the settings stuck. However, as soon as I open a project in developer mode again, they are instantly reverted.

Doesn’t save at all here either.

Basically everything that’s important has been broken once again…


also broken for me

1 Like

Xbox Series S, with a handful of sim restarts, the settings have reverted to Easy every time.


The third time around after I restarted the sim it seems the settings are now fine (ie. back to Hard) and didn’t revert. Let’s hope it stays this way. Not sure if it helped, but I also refreshed them during a flight and not only from the main menu.

1 Like

I have the same problem… Set the assistance options to hard , applied saved exited the Sim restarted back to easy…

1 Like

Yay, it worked even after the usual CTD. That’s good news (probably).

It’s beyond belief how poor the quality checking is on this sim. This bug has appeared since the beta was in test !!!


The sim has numerous Sub Contractors

Maybe its time they sub-contracted a Professional Support Company that specializes in Independent Testing and QC … ?


I am not struck with this between every flight… However I can confirm that I have just been struck with the assistance options all being reset to easy between flights.

I was jumping in and out of VR and also experimenting with different shortcuts to view points, using, e.g. ctrl+0. Not sure if that could be a trigger:

The only other difference was I downloaded an update from the content manager due to a marketplace update that was available just before the affected flight.


same thing here but its not a major issue

I had it reset on me after restarting the sim and once after doing the spotlight landing challenge. (Including having to reset the mouse profile again) A 3rd time restarting (after getting the Reno content) it did keep my settings.

Just tried another restart and no reset. Fingers crossed for tomorrow.

6 hours of installing, reconfiguring, testing, deleting, restarting, downloading, more testing, time for a break!

we spend more time doing Asobo’s job than flying, that i think is our hobbie, bad sign


Same here - settings reset between flights.


Just loaded Sim changed settings to Hard, loaded a flight, did a circuit. Quit back to windows, restarted the Sim and Settings remained on Hard.

Steam version.

After getting everything updated I went through and put all my setting back where I wanted them then started a flight.
And all the assist were back to easy.

Changed all my settings again and closed the game, rebooted my computer, restarted the game and started a flight and all was well. Started a second flight after I crashed the F-18 and setting still where I left them. Hopefully they stick now.

I just don’t know how Asobo is doing such terrible testing. The users discovered this bug in a few minutes and they could not detect it for months. Ridiculous


My assistance options were all reset to easy after the update. I changed them back to how I want them.

Then, tonight, an additional update showed up in the content manager for one of the marketplace planes (the ultralight, I believe) and after installing that update, all the options were back to easy. I changed them back to how I want them.

Then, just now, I purchased and downloaded the $20 Reno Air Race pack and after this, all my options were back to easy. I will once again change them back to how I want them.


I am trying to work out what triggers this reset of assistance settings to easy as it doesn’t seem to be happening consistently.

@uncmonkey and I have both had it happen when content manager updates something (including marketplace update or a purchase).

The more detailed information we can provide as to how to reproduce this issue consistently the easier it may be for the devs to fix it.


Also had this reset on me today, seems to be after tweaking content cfg by updating or changing scenery or community files, or downloading new Asobo updates in the content manager. Sometimes good sometimes not so good.