Intolerable flashing in top third of screen since update

WOW ! They need to correct that ASAP.

2 Likes

For me the 10.8.0 update has solved this.

Thanks ASOBO!

Having the same problem on my gtx780ti I hope Microsoft reconsiders…for me I am returning to P3D maybe in january I will buy a rtx 3070 when available

Unfortunately, negative on GTX770 with 10.8.0.

10.8.0 doesn’t solve it for M2000M

Agreed. The game is unplayable after the patch due to flickering. Is there any chance of getting a refund?

1 Like

AlienTrucker above suggested that he asked for a refund was denied one.

Pas de panique, ils vont trouver la solution… attendons un peu.

We now have three reports of people being informed that they are not planning to fix this issue because the minimum requirements will be shifting over time, and one person being denied a refund due to this. We have plenty of reason to panic right now.

1 Like

This is a gnarly bug. However, I am running GTX 960 and found that Pushing esc or Start with Xbox controller multiple times will get rid of the bug for a moment. I keep doing this until I am satisfied. I also noticed that mid flight it tends to go away.

Have (very swiftly) received a response to a bug report. My GPU is gtx960m, I’ve been running it fine on medium, even some high settings since August and their response is that I’m ‘asking too much of my hardware’. No word as to why my hardware was able to meet that request last week but not now. Also received a slightly patronising list of the hardware requirements, and a suggestion to ‘turn everything to minimum then gradually increase quality until it occurs’.

So the line seems to be it’s nothing they’ve done, but in fact my fault for making the same demands of my hardware as I have been doing for 2 months.

2 Likes

Is it the GTX 960 or the laptop variant GTX 960M? If it’s the desktop version, then that would be the first report of a Maxwell 2.0 GPU experiencing this issue.

Thanks, unfortunately someone else received the exact same response earlier today. That makes for the fourth report suggesting that there won’t be a solution for this. It’s not looking good…

This is the exact reply I got fyi. My main hope here is that this was auto-generated based on my issue, because otherwise it seems we’re SOL.

1 Like

speechless

1 Like

I received the same response about an hour ago. I sent the following in hopes that there would be a way to revert to a previous version…

Can you please tell me how I can revert to the previous version where all the capabilities of my hardware were able to run MSFS2020 to my satisfaction including using all weather presets for cloud formations as well as live weather? I cannot afford to upgrade my hardware and since the sim previously was fully functional I believe this would be a solution that all of us… MS, Asobo and I would be satisfied with.
Sincerely,
xxxxxxxxxx

4 Likes

ITs the Variant 960 M on my Asus Zenbook
But, I did the clear sky settings and seem to not run into issues

1 Like

Unfortunately it seems that this was not auto-generated, but created recently as a response to all of us having this specific issue, since they are suggesting to completely turn off the clouds.

Well - auto-generated as in a stock reply that doesn’t consider the individual problem, else it wouldn’t be calling everything from recommended specs (our 960Ms) to absolute minimum (the 770/750s). Hopefully we’ll generate enough tickets for them to acknowledge this as a specific problem.

Real shame, I was only thinking the other day what an achievement it is to get this playing acceptably on even older systems, you don’t get that with many sims. And now you don’t get it with this one either!

Have received a definitive reply, I think.

“This is not a bug, it is an improvement to the cloud system that lower end video cards are having issues with.”

So, this ‘improvement’ has kicked a few thousand people out of the game’s community. So it goes, and sucks to be us!

5 Likes