Is "Force Feedback" gone in Windows 11? Any Sidewinder FF2 users here?


I’ve got an old Sidewinder Force Feedback 2 joystick. I know that FS2020 doesn’t support FF, but in Windows 10, the “motor” of the joystick was always active when you grabbed it, in the sense that it would give some resistance and pull the stick back into the center. Even if you were just on the Windows desktop, not in a game.

I’ve recently upgraded to Windows 11 and shockingly I’ve now noticed that there is no resistance anymore whatsoever from the stick now. It just dangles around. This makes it very hard to use, as it also doesn’t have any springs (like non-FF joysticks) that would bring it back to the center.

I don’t think my stick is broken… has Microsoft really completely removed FF from Windows 11 and therefore pretty much destroyed the usefulness of this joystick?

There must be more people here with a MS FF2 joystick. Has anyone noticed the same?

Thanks a lot!

My MS Sidewinder FFB 2 flight stick works perfectly in Win 11 like it did
in Win 10. (uses XPForce)

Have you reinstalled the driver in Win 11?

what does XPForce add to ffb?

I dont know, may be coincidence. I used it fine in w10 but when i went to w11 my sidewinder2 smoked. I used it for hellos, kinda cool…

There are a good few people here using FFB sticks, both MS and Logitech. Do a bit of a search and you will discover much. XP Force for me, is as good as it gets for now, at least.

There are some threads where you can vote for native FFB support within the sim, so don’t forget to add your vote appropriately.

1 Like

It provides the software required to create the forces for the flight stick.

That software does not exist in Windows 10 or 11 or FS2020.

No need for joystick software IMO. My Microsoft FF2 joystick works as perfectly in Win 11 as it did in Win 10. I do use XForce with it in MS2020. I use Russell Dirk’s FF2 software in P3d. Those programs are the only ones needed for both flight sims.

Hmm, interesting that there are quite a few people here who’s MS FF2 joysticks motors work in W11 as they did in W10. There is no driver or software to (re-)install, it was always just “plug in and it works”. And it would be a bit of a coincidence if the motor broke exactly when I updated to W11.

As I said in my original post, I understand FS2020 doesn’t have/support force feedback but as I was describing, I’m referring to the motor force that pulls the joystick back to the center.
The motor is usually inactive when your hand is not on the joystick, but as soon as you grab it (it has some sort of optical sensor at the back where you grab it), the motor force activates and pulls the stick to the center.
So you guys really still have this working with the FF2 on Win11?

Moved to #self-service:peripherals

If I understand your question correctly:

The MS Sidewinder FFB flight stick under Win 10 and Win 11
has no resistance. It feels like it is flopping around.

It works fine as a joystick but there is no centering.
Even when calibrating it under Win 10, there is no automatic centering for it.
The center is where you leave the stick during calibration.

With XPForce software installed, the flight stick does self center.

Not quite. The joystick was working completely fine under W10 - always. Only in W11, it was “flopping around”. I do not use XPForce (neither on W10 nor W11).

However: I am happy to say that it has resolved itself now. After a reboot or two, and re-plugging the joystick again, the motor now works again and it’s centering - exactly like it was working before.

Seems that it was just a one-off where something odd happened when I plugged it into Windows 11 for the very first time.

Thank you all!

Yeah, this is what most people seem to misunderstood. A “plug and play” isn’t necessarily plug an play. There is a basic firmware that hardware runs for basic input purposes, but advanced features such as force-feedback capabilities require specific codes to run. And that’s where Drivers come in.

What most people think of plug-and-play is actually the hardware automatically installs the driver (or the OS installs the driver based on the hardware that’s being plugged) in the background without you realising it. So in most people’s perspective you plug it, and it works. But it’s not that simple in terms of the programming behind it.

The reason why I said to manually install the driver is that if for some reason this automated process doesn’t work due to various reasons (the OS unable to detect the hardware, or the hardware itself doesn’t think that it should inject the driver into the computer, etc), you need to be able to install it manually. But given the age of the MS FF2 hardware, it may be difficult to secure an official driver from Microsoft.

And this is my point exactly, perhaps the first time you plug it, it’s having difficulty installing the driver automatically as I explained above, which makes the motors not working. But since you unplug and re-plug it again, the automated driver installation might have worked then and you can finally use it. Or that it did install the driver, but it won’t finalise until you unplug and replug the hardware. Regardless, it’s great you have it working now.

Yes, there hasn’t been an “external” driver to install for the FF2 for decades now. Back in 2000 or whenever it came out, it was on a CD-ROM, but when Xp, Win 7, 8 came along, as it was Microsoft hardware, the driver, calibration etc. all got integrated into Windows. Yes it still needs to “install the driver” the first time you plug it in, but it comes from Windows DLLs that are already there (or distributed via Windows / Windows Update).

Back in the days, you’d plug in a device, and you’d literally have an exclamation or question mark in the Device Manager, and Windows would not know what the device is, without you installing the vendor driver from a zip-file / CD-ROM / internet. A joystick or network card would literally not work at all until you install the vendor driver. Or when you started Windows for the first time, you’re greeted with a 640x480x16bit Desktop because Windows doesn’t recognise the GPU. These days are long gone, almost any device you plug in nowadays gets recognised by Windows, and the driver is already there or in Windows Update.

I use the Logitech G940 FFB and XP Force together and they are as good as it gets with MSFS. Or so I thought…

The other week, I downloaded FSrealistic on almost a whim, but have been delighted to find that this adds another dimension to the sim. A lot of things that weren’t there before now are. There is force feedback for

Touchdown and take off

All felt through the stick along with both sound and visual cues. There is some varying rumble from the runway surface as well, so you can feel the aircraft either wanting to fly or planting itself more firmly onto the deck.

Flap and speedbrake

Felt and heard too.

This along with several audio and visual cues has provided quite an eye opener here and the program is fully configurable as well. For me, I got rid of the human sounds ranging from applause to screaming and am left with something much nicer than before. It rounds out the FFB experience really rather well. I find it helps you “feel” the aircraft much more and takes out that slight feeling of sterility. I pass this on purely for info.

Late edit…

I seem to remember that there was a trial for this program as well and if there is, then you can see how well it works for you before splashing out.

1 Like

Wow, thanks a lot for writing down your experience, that sounds really cool! I’ll make sure to give FSrealistic a go, they do have a free trial! Thank you!

My pleasure. Enjoy!

1 Like

I have a force feedback 2 and it worked fine with windows 10 for a while except with the motor working. Now I am experiencing flight control system malfunctions. Very glitchy. Throttle, rudder mostly. I have no software for the controller. I had to name it and map it for MSFS 2020. Any ideas?

Did you plug it into the AC power?

Calibrate it under Win 10?

1 Like