Is it normal that the Cub Crafter X Cub - Floats can't steer on ground?

Is it normal that the “Cub Crafter X Cub - Floats” can’t steer on ground? Steers great on water, but on the ground the only steering you get is when you’re going fast enough for the rudder control surface to have an effect - which is too fast for taxing. Or is this a bug?



It can’t be normal. I’ve tried both rudder and differential breaking and combo of both and can’t get it to turn in anything less than a soccer field.


Exactly the same to me. Left brake or right brake produce identical results - slowing the airplane in its forward momentum without turning one way or the other (like how you can almost pivot in place with ~50 percent brake on just one wheel - not possible on this airplane currently either).

For me the new amphibians (X Cub and 172) can’t steer on water. Or rather, they can, if you’re satisfied with having the turning circle of a cruise liner.


That’s so totally opposite for me. Steering on the water is great, at least as good as the Icon A5. But steering on ground is unusable. Always amazes me how inconsistent this game is to the point people can experience polar opposites of the same bug on the same release version.

You can see by the wake effect in this screenshot how “well” they turn for me on the water. This shot is taken with full right rudder at a speed of about 12kts.

But after some more testing, it looks like they don’t really handle any better for me on land. Would have great difficulty negotiating most taxiways to get to a parking spot. I wouldn’t say they’re really taxi-able in either environment - strictly “spawn on the runway for takeoff, end the flight on the runway after landing” planes right now, which is disappointing.

! WATER … The water rudders don’t work, making it a ridiculous claim. It doesn’t for sure taxi on water.

1 Like

Have just tried taxying the XClub with floats, on land. It really is an insult that this thing can’t taxi on land or water… why even release this ? ! WATER

1 Like

If you want an amphibian that CAN taxi on land… Bush League Legends - MSFS Aircraft . It does not taxi well on water because the water rudders don’t work but at least it taxies on land! ! WATER (The BIrd Dog amphibian also can taxi on the ground.)

1 Like

Mine work fine!

Did you lower the water rudders?

1 Like

Yes, of course. They animate but don’t actually do anything. The turning behavior is the same with them lowered or raised.

The only floatplane for the sim which handles nicely on the water right now is the Aeroplane Heaven Cessna 140, and ironically its water rudders don’t animate right now as it waits for a SU5 patch.

1 Like

Ok…. so it looks like it’s different from User to User. I tried the 172 on floats. The waterrudder works fine. I can turn the plane on slow speed in a tight angle.

I have just retried the C172 Amphibian and the water rudders do NOT work. There is no difference when you deploy them. A developer has confirmed this as he can NOT code for this. The new update, apparently, has not fixed this. Perhaps you could post a small video of you water taxying to a pontoon…

Sure, as soon as I’m home, I’m taking a short clip.

Which airport has a pontoon?

Return to Misty Moorings - FS2020 Home Page


I don’t think so considering the other two planes that have been augmented with floats (Zlin Savage Cub & Cessna 172) can taxi.

As an aside the rudder mechanics have always been a bit wonky, at least on the Icon A5.

The Icon is the easiest aircraft to water taxi to a pontoon. At idle it will revolve around its own axis which is very helpful for not smashing into wooden planks. I just don’t enjoy flying the Icon as much.

1 Like

The 172 also has non functioning water rudders and the turning radius of an oil tanker.

The water handling on the Icon is also very unrealistic, albeit in the other direction, but at least it’s unrealistic in a helpful way.

The OzX Goose Redux also handles well on the water, because the developers gave it “invisible” water rudders to compensate for steering with differential engine power not really being possible in the sim right now. It’s rather tedious that third party developers can get this to work when Asobo seemingly can’t.

1 Like