Issue with center gear animations

Also Flightsim keeps crashing every time I resync after making changes :confused: Anyways ill keep playing with it. Im sure its something simple.

I’m pretty sure the issue is with the contact point based on my past experience as well. I had neither steering nor suspension animation working until I readjusted the contact point position. It looked totally fine but it didn’t work. Weirdly, the editor is not showing if the contact point is wrong. And CTD on resync definitely doesn’t help now.

Ive played around with the contact points a lot and nothing works. Maybe i’m not doing it right?

Well, the other things I changed included Empty Weight CG position and MOI in the Weight and Balance section. It might affect the expected contact point position by the game engine. Also, a static pitch might need to be checked.

Now I just tried to parent the center tire empty to the suspension empty. The suspension has a keyframe at 0 100 and 200 with 200 being the compression. but they go invisible when in game. If I clear the center tire parent, the tire shows up but the suspension is still invisible. Suspension animation is named “Gear_Center”. I’m struggling with these front wheel animations. I did the rudder, flaps, elevators, and ailerons with no problems but this center gear and tire are super annoying.

Man, I hear you. I nearly gave up myself when I couldn’t make the front gear steer for several days. And then I stumbled on a video showing SimvarWatcher from the SDK samples, launched it to check gear steering angle, and realized that it stays at 0. That’s when I figured that I had a contact point issue and came back to tweaking weight and balance and wheel points. I wish I knew what was wrong exactly, but I have no idea what fixed the issue.

1 Like

I have no clue why it would go invisible. It’s really weird but might explain the problem you have with it, somehow. If you can share your blend file I can take a look if I could spot something? I ran out of ideas

It may not be totally disappearing but the empty is taking all the child objects and its going to the world origin point when I do location keyframes. Any ideas?

Oh, that’s probably because you changed parent after animation. References are messed up. You might need to re-animate

No its still doing it. I tried animating just the suspension without the empty and it stayed in place but didnt move up and down… sorry this is probably annoying for you lol. Maybe ill send a blender file and you can see if you have any ideas

By the way, you don’t have to use empties for animations if you can avoid it. MSFS is totally fine with animations using part’s origins. My front gear for example is steered by rotating strut itself, not parent empty. All other parts are children of either strut or other child in the same tree.

1 Like

Tomorrow though because ive spent too much time on this today and got nowhere lol.

OK. I can take a look.

Yes, sadly that is a common feeling when you are desperately tweaking stuff in your add-on aircraft in order to get some detail to work. I really wish there was some kind of log file or window that would give information useful to add-on aircraft developers. The output in the current “console” dev mode window is mostly useless (unless you have a WASM module doing something, then you can print out whatever logging you need). Most of the stuff in the console window is about errors or warnings in other aircraft, even bundled ones. Very little information about the aircraft you are working on, which is what one would like to see.

Hi Viper,
Have you any solution in this matter?
I have exactly the same problem than yours.
I can animate left and right gears and spinning tires with no problem. But I can’t animate the nose gear. I made a cross-check: just rename ‘Gear_Center’ and ‘Tire_C_Anim’ in blender to ‘Right_Gear’ and ‘Gear_R_Anim’ and tadaaa the center gear start to work…ergo the animation is good, there’s a bug in the xml and/or simvar name? I ran out of the ideas… :frowning: