Issue with center gear animations

Hi! I’m in the process of developing the Tucano for MSFS, and I just want to know if you’ve ever come across issues with the c_gear, c_tire_anim and c_wheel animations not working properly in sim and constantly show at frame 200, regardless if the gears are up or down…they’re all defined correctly within the .xml and assigned in 3ds max. Hope you can help!

MSFS | Tucano T1 | Nose Gear Animation Issue - YouTube

This is what’s happening with the gear…also my ailerons are all of a sudden inverted I just noticed and idk why aha

I have the exact same problem right now, its SUPER annoying because the other wheels are fine but everything to do with the center tire and steering doesnt work. Any fixes? How is the center tire rotation and steering named?

If you want to use Asobo templates, the template name for center gear movement is “ASOBO_Gear_Center_Template”

Your animation would need to start with the gear up at frame 0, fully down and decompressed at frame 100, and suspension fully compressed at frame 200.

Animation name should be GEAR_Center

Part/node names don’t matter

Thanks for the reply. Im mostly talking about the GEAR_Center_Tire template. and the GEAR_Steering part. I havent done the retraction of the gear yet. Just trying to get the center tire to rotate around the empty in blender. The left and right wheels are rotating just fine and if I name the center tire “l_tire_anim” it will finally rotate but only with the left tire. So i need to get it on its own. In the XML I tried the default names, GEAR_Center_Tire and tried c_tire_anim but nothing will work. Also the steering I have 0 to 360 frame and it wont rotate, its stuck on frame 0 which means it reads that its there instead of it being centered like I had it before. Ive spent DAYS and DAYS on this so if anyone can help me I’d be forever grateful :smiley:

For the steering, animation name is GEAR_Steering. It should be 360 degrees clockwise when looking from top down. Template name is ASOBO_Gear_Steering_Template

I didn’t do tire rotation yet

Please use SimvarWatcher from SDK samples to confirm your game feeds steering angle data. I had a similar issue with steering and turned out my model had some kind of an issue with contact points. I tweaked them back and forth and it started to work, somehow. I wish I knew what was wrong exactly, but no idea

I should animate the steering empty to go 360 degrees around the Z axis in blender? I only animated it to what it should rotate in real life. Hmm

Yeah, it should go from 0 to 360 entire circle, I have it with 90 degree steps. The simvar code for this template takes the angle and rotates the gear based on data in cfg

Okay I’ll try that thanks!. Now for the wheel rotating let me know if you get it working. :smiley:

Well, I left tire rotation for later and am doing gauges, but I can take a look at it today or tomorrow since I will have to do it some day anyway. Will let you know

1 Like

So, I just tried it really quick but it worked perfectly from the very first attempt.

I added <UseTemplate Name="ASOBO_GEAR_Center_Tire_Template"> </UseTemplate> to the model exterior xml file.

Then I just followed the logic set in the template as per Exterior.xml

  • In Blender, I added an empty and named it GEAR_Center_Tire, and placed it at the center of the front wheel
  • I put it as a child of other moving center gear parts so it moves up and down with the suspension
  • I then made it a parent to two tire meshes: GEAR_Center_Tire_Still and GEAR_Center_Tire_Blurred
  • Next, I added animation to the GEAR_Center_Tire node, 0-90-180-270-360 frames for 360 degrees rotation (since ANIM SIMVAR calls for an ANGLE), as if it rolls forward. Animation name matches node id, as usually (GEAR_Center_Tire)

Saved, exported, opened the project, rebuilt package, loaded on apron, started to move and the front wheel rolls nicely in the correct direction.

Still doesnt work. This is the weird part. All I have to do is change the center NLA track name to the left or right tire…“GEAR_Left_Tire” and it will spin but when I do “Gear_Center_Tire” it wont. Ive copied the same .XML text from the default and changed it 10 different ways and check all of the spelling, deleted the empty and re did it…I dont understand it.

It shouldnt need a blurred mesh or still mesh for it to work right. The left and right tires dont have either and they spin fine.

Check contact point for the front gear then.
If you didn’t animate suspension yet, make sure you set springs/dumping correctly for rigid suspension before setting the contact points. The game emulates compression even with static suspension and this might result in some issues. I had a problem with the front gear because of it.

In the Aircraft contact point debug, its reading the RPMs and it has a weight on wheels of over 2000 lbs. Should be good right

Maybe ill make a video for you lol

It will show weight and compression even if the gear suspension is not animated yet. That is what fooled me as well. Change front gear stiffness so it shows 0 compression since there is no suspension animation, then readjust contact point so the wheel is on the ground, and see if it starts moving

Sorry change front gear stiffness where? Static compression to 0 in the contact points menu?

Yeah, the contact points menu in the aircraft editor has damping and some other settings for the suspension. Don’t recall exactly, not in front of the PC already to check. You need to make suspension rigid, so the bars in the debug window show 0 compressions. Then set the contact point so the wheel is on the ground properly.

Dont think its working. Compression is at 0 but still nothing.