Issue with engines on the Baron G58

Occasionally when I take the runway for takeoff and just before advancing the throttles both engines quit. Nothing I have tried will restart the engines. I have tried right control + e without success. I have the Honeycomb Alpha Yoke and the starter switch has no affect. The only thing that sometimes works is a complete reboot of my system. I currently have an old CH Throttle Quadrant attached to my system. On two occasions only the right engine shut down. Only once has the right engine failed in flight and even with engine feathered, I shortly crashed. As a final try, I re-bound all my settings with no change. Does anyone have any ides as to what to do? I have ordered the Honeycomb Bravo Throttles but I wont get them until November of 2021.

1 Like

Forget about my earlier post. As indicated earlier I find that if I look long enough either it resolves its self or I find a fix. In this case I found a fix and it turns out it was something I did. So, thanks everyone I am off and flying for the present. It will be much better when I get my new Bravo Throttles. One thing I find distracting is the instability of the airplanes. I have flown Beechcraft, Cessna, Piper, Mooney and many other and all once trimmed for flight you can mostly just sit there but with everything, I have flown in the sim I have to work hard to keep it under control. Constantly adjusting pitch, roll, and yaw, very stressing.

I am having the same issue with Flight Sim to I have a HOTAS Logitech x52 Pro and can’t get past tutorials’ just got it a day ago cleared any mapped keys to Engine start and same issue

In my case I wasn’t getting full power. I ended up changing the position of my throttle quadrant which seem to have solved my problem. I am sure when I get my, Bravo Throttles everything will work better. I am sure Logitech has a support line that should be able to help. I have used them in the past and always had pretty good luck.