Issues With The Switches On The Bravo Throttle Quadrant

Today when I went to take my Bravo Throttle Quadrant out and set it up I noticed that none of the toggle switches and AP mode selector buttons are working, in MSFS. I then, as a troubleshooting step opened up the Windows Gamepad settings menu and saw the buttons and switches did not do anything when activated. Here is a list of troubleshooting steps I have taken so far.

  • Unplugging and replugging the device

  • Restarting both my PC and MSFS

  • Tried plugging it in to a different PC to no avail

  • Used a different (known good) USB C cable

  • Updating and reinstalling the Honeycomb Drivers

As a note all other buttons and axis appear to be working fine. But I have not had the time needed to check each and everyone of them. Does anyone have any advice on a solution or failing that know a good way to contact Honeycomb support? I tried to submit a request a week ago and I have heard nothing back. So I was wondering if anyone knows of a different way to contact their support as their help desk does not seem to be checked at all.

Not very clear on your problem. Is this the first time you’ve connected your Bravo? Has it worked before?

Where are you testing the Windows Gamepad?

Here is a link to a Game Controller testing website. Are you seeing any input?

Edit: FWIW, my toggle switches don’t show any function when checking them on either Gamepad Settings in Windows or the website I linked however all of the Pushbuttons on the Bravo do register on both of those testing apps. Once in the sim though, my Toggle Switches perform exactly as they should. Are your pushbuttons working in the Windows Game Controller app? If so you don’t have a problem with the Bravo and as I said, once those Toggle Switches are mapped in the sim they should work just fine.


This is not my first time using this Bravo and it has worked correctly in the past. It just started happening recently. The issue is that the autopilot buttons (not the mode dial) and the toggle switches below them as well as the landing gear toggle either report as being pressed 100% of the time while not seaming to provide any input to the sim or they will be 100% off regardless of input. This behavior persists trough unplugs and replugs and full system restarts.

I had to set the control mappings. My Bravo did not have any preset profiles. Once I manually set them, it’s worked great for the autopilot and all other assigned buttons.

Well then yes, it sounds like you do have a problem with it. There is another thread regarding Honeycomb customer service (link here) and I’m sad to say the response has not been good. It seems your best approach may be to contact them by phone or Zendesk. If it were me, I’d be persistent on the phone.

Fortunately for me at least, my Alpha and Bravo have so far performed flawlessly but I am very troubled by the number of folks who can’t seem to get support from them.

Good Luck and maybe you can join the thread I linked and keep us posted on the outcome. There are many of us with Honeycomb products and I’m sure we are all hoping for good outcomes regarding warranty and customer service response.

1 Like