Japan World Update won't load

Hi to you guys! I installed the Xbox Version on a Series S and everything runs fine so far. I could also download all world updates. Unfortunately, the Japan is update is stuck and even after deleting and re installing the whole game, it still just won’t load. There are no error messages, except that it says “Errors: 3” for the packing instead of showing the download size. Can anybody help? Thank you so much!

Same Problem with World Update IV France on XBOX Series X :frowning:

1 Like

Was it also the first World Update you tried to download? And did this error show up on launch day just after the game was released?

Error 3 on LaunchDay … deinstalled … Newinstalled … Same Error

OK, seems like exactly the same problem. Have you cleared your Cache before the re-install?

Same problem here too. There are other users in the same situation in other threads


I couldn’t find any :scream: so there are really no solutions yet?

Looks like there will be an official update later today. Let’s wait and see

It didn’t solve the problem for me though

I wrote a Ticket… here the answer:

It seems you were missing a few entitlements.

The entitlements have been manually redeemed on your account, and World Update IV: France should now be available to download and install now.

If Error 3 remained, please let us know and we’ll investigate further.

… i can test it on Sunday first :tired_face:

Now its OK. Its loading​:hugs::hugs::hugs:

Think u must write a ticket also🤔

I’m still waiting for their reply. But good to hear :slight_smile: have fun in Japan!

1 Like

They could also help me :slight_smile:

1 Like


I opened a ticket also and I received the same reply. Now all is working.

1 Like

Super :+1: the Support is TOP