Joystick to SimConnect Mapping Utility - Honeycomb Bravo Throttle Mappings Included

Version 0.6.1 released.

Added long press events.
Added ability to send multiple events with a single HID Event.
Added ability to specify the data to send with each SimEvent.
Added ability to send an event multiple times in a single HID event.
Added ability to specify both press and release events for a HID event.
Added mappings for the Logitech Flight Multi Panel.
Added mappings for the Honeycomb Alpha yoke, un-tested as I don’t have one.
Documentation updates and improvements.

I just released a new version and all SimEvents documented in the 0.9.0 SDK are implemented.

BTW feel free to make any improvements to the code you think are appropriate and send me a pull request.

As far as I’m aware the bug will affect any rotary encoder type control that is used when a switch or button on any device is constantly held in the “pressed” state. So I think that your Warthog problems should be solvable with this app.

As @Volt580 says this is ultimately an Asobo problem to fix and I look forward to the day when they render this use of the app redundant. I think that it will still be useful then because of the other functionality it provides but I suspect that I’m biased :wink:

1 Like

Terrible sorry I ask this, I am just trying to learn this fascinating way to control the sim.
Quote: (Re)start MSFS. Now you can input the SimConnect events below to control your systems!
Where exactly you input the Simconnect events and how you assign them to a physical button in your device like an Xbox controller for instance? Thank you

You are quoting from the instructions to install the MobiFlight module. This module does nothing by itself, it just enables some of the SimConnect events that are currently not enabled by the sim itself.

To make use of these events requires the use of other software of which my app is one, others being vjoy+joystick gremlin, the full MobiFlight suite and others that don’t readily spring to mind.

If you own a Bravo throttle my app should just work out of the box - albeit that it might not have exactly the mappings that you want. Changing the mappings is currently done by editing the JoystickMappings.xml file with any text editor.

1 Like

Hi, I think even when they fix this, there will still be events which cannot be assigned directly using the “Controls” panel within MSFS. And then with this software you are able to map a button to a SimConnect Event that can do it :slight_smile:
Also you are more free to let the encoders behave the way you want (concerning speed and accerleration) which is not possible by just using the internal Control options of MSFS.

Your explanation helps a lot, thanks

Hi and first off thanks for this neat little tool. I’ve downloaded the latest version and after fiddling about somehow noticed the greyed out option for Honeycomb Alpha and Bravo was clickable.

Sad to say I’m not sure how to set it up so that it works in the sim. I have used SpadNext to load a profile for the alpha yoke which works, (once I delete the bindings for the always on buttons on the yoke in a new profile) but haven’t tried it yet for the Bravo in Spad, as it’s a really complicated software, hence me trying your tool as a simpler way of getting the job done. I tried the same procedure unbinding procedure of the always on buttons, with both the alpha and Bravo, but got no functionality in game. The heading bug was gone though, which I expected. I was especially confused on whether or not to cleard the rotary left knob settings (alt vs etc).

If you could talk me through the correct procedure to get this to work on the Alpha yoke and Bravo quadrant that would be greatly appreciated. I’ve only had the Bravo for two days and my brain is reeling from setting up so many profiles for various aircraft.

I’d suggest you hang fire for a bit. Another person has already alerted me to a problem with the Alpha yoke profile which is actually caused by a more serious underlying bug in the code. I am diagnosing it right now and hope to have a hotfix release available soon.

I’ve got my Alpha Bravo combo fully working using vJoy and Joystick Gremlin
I posted my profiles here

OK. I also noticed an unhandled exception error when I first fired up the program. See screen shot below.

yeah you gotta instal the the prescribe .net framework from microsoft
See 1.1 on the page linked below
Joystick Gremlin (

Thanks, I’ll give this a try and see how I go.

That’s the bug I was referring to - I have a fix that I’m testing now and will release a hotfix very soon.

1 Like

Hotfix v0.6.4.1 is released. Get it from the same link Latest Release on GitHub.

Please don’t keep using v0.6.1.2 as it has a couple of serious bugs - it won’t blow up your system but it will give very weird results with Honeycomb type switches.

Hi all. Its a great tool that E1ephant42 made for us all. Really appreciate his work.
He currently does not own a Alpha yoke, so I try to assist him as much as possible setting up a profile for Alpha and Bravo owners.
Right now there still seems to be an issue with the Alpha and Bravo combined profile and I reported all the details to him.
For me as of now no button presses are registered and therefore no input is generated within the sim when selecting the Alpha and Bravo combined profile.

The Bravo only profile under v0.6.1.4 works great.

It would be great to hear from others if they have the same problems, or if they can confirm that it works.

Thanks & bye


It seems from the feedback @Ziesel1106 sent me that there is some sort of conflict with the Alpha yoke and my app. I can’t see any obvious problem with the profile and the combo of AFC_Bridge+my app+Bravo throttle works perfectly for me. Without an Alpha yoke there is not much more I can do.

If someone who has .NET debugging skills as well as an Alpha yoke can debug the issue and let me know the results I might be able to get it working, unitl then, I’m sorry :frowning:

Sad to hear it still has problems.

OK, after thoroughly reading the pdf, I tried the app out with the combo of Alpha and Beta in a C172 Garmin. No panel switch functionality with the Alpha Yoke at all. The Yoke press buttons all worked as mapped. Mag switch and starter, nothing.

On the bravo, AP was dodgy, the App could be turned on and off on the Bravo, but the AP green light in teh PFD stubbornly remained on, even if I tried the mouse on screen.

Of the 7 panel switches, only the pitot heat worked, all the other light switches were dead. Though I’d have assigned them solely to the Alpha and have other useful stuff on the Bravo, like parking brake, yaw damper de-ice etc.

No heading bug or altitude 1000ft increments, but the trim wheel, although it moves in smaller increments, looking at the wheel in the cabin, it was impossible to stop it overshooting and either climbing or descending at stupid VS (obviously with AP off).

Will now try the Default bravo only, simple mode.

OK, just tried the Bravo only, again in the C172 Garmin and it mostly works OK. Panel switches 1 + 2 inop, as per the default table in the pdf manual, the other switches worked.

Flaps were inop on the Bravo flap switch, I’m guessing I didn’t need to unassign that lever as it’s momentary, not always on. Duh.

Trim was OK, much better than in the combo.

AP worked OK, but when I click off the AP on the Bravo panel it disengages, but the AP light stays on in PFD.

Heading and altitude select were in degrees and 100ft respectively.