Joystick, xbox controller stop working

This one is weird. Whilst everything was working fine in a previous VR flight, suddenly my joystick (Logitech Extreme 3D Pro) and xbox controller no longer worked loading into a new flight even though in the menu the axis movements for control surfaces show them as working. Also all keyboard commands stopped working except for escape and the exit out of VR assigned button. Nothing else (engine start, camera control etc.) would work.

Any idea why? Did I disable something in flight?

Sounds like just the opposite. You may have inadvertently enabled the ai pilot. He now has control.

I tried turning that off thinking the same but it made it no difference.

In developer mode there is a selection for “real cockpit” or something. Can’t remember the actual name but you will know it when you see it. Make sure it is off. That will muck up the controls.

Okay. Thanks. Will take a look. Developer was not enabled.

You don’t have to keep it open once you find it either. It is a persistent setting. Some have had it activated after doing updates.

Ah ok. I’ll check👍🏻

I’ve just started getting this happening, from time to time, and although a restart appears to sort it out, more often than not, it is still a bit of a pain.

Did the possible solution offered by @willisxdc correct the issue and if so, could someone please point me in the direction of where in developer mode i might find the offending parameter?

this has happened to me also whenever I was using the 787.

I’ve only just started getting it this evening, after updating my Windows to 20H2, which might be a total “red herring”, but probably worth mentioning.

The only other thing i did, was to assign the ‘Reset VR view’ command to one of my controller buttons, as well as the existing spacebar mapping.

hmmm, for some reason, it looks like it is loading in pause and you need to use the resume option in the developer mode options drop-down to clear the pause. the keyboard commands, won’t get it done, for some reason.

I’ve checked my controller mappings to make sure that there are no controller buttons set to the pause command, but I’ll keep looking to see if there is another finger-trouble “crime” I’ve committed.