KDEN Dever Flightbeam double scenery

The default scene is not cut. How to fix it ?

Remove Asobo’s KDEN if you own MSFS Premium-Deluxe (Double buildings)

Post by Mir // Flightbeam » Mon Aug 17, 2020 10:24 am

If you own MSFS Premium Deluxe, you must remove Asobo’s KDEN in order for KDEN to display properly. This can be done by opening the Content Manager in your profile section in the game, and searching for KDEN.

Unfortunately in the release build, Asobo/MS introduced a Content Manager bug which prevents users from deleting/disabling packages (airports/aircrafts). Follow these instructions to disable the default KDEN (premium-deluxe version)

IF YOU PURCHASED FROM MS, open this folder (default location)

IF YOU PURCHASED FROM STEAM, open this folder (default location)
C:\Users\YOURUSERNAME\AppData\Roaming\Microsoft Flight Simulator\Packages\Official\Steam\asobo-airport-kden-denver

  • Delete: “layout.json” and “manifest.json”

  • Do NOT delete anything else, otherwise the package will re-download again


I assume you have premium deluxe with the handcrafted KDEN. Did you disable it in the content manager under profile?