Keyboard Stops Working

As soon as I hit the ‘FLY’ button the keyboard stops appearing as a controller until the flight has ended, which can only be done by parking at a stop point or crashing.

Anyone got any ideas?

Not a one, please file a bug report on Zendesk, using the “Submit a Request” option on the top menu bar. Include a detailed description of your issue, as well as steps to reproduce and screenshots if applicable.

Done that, initially 25 days ago, hoped the patch would fix it. Tickets 37110, 37116, 48013, first two closed following the patch to try again now. Latest one placed 12 days ago which was just replied with a generic “don’t plug stuff in during a game/disconnect other stuff/reinstall drivers”, with a link to and a suggestion to post here too.

It’s a keyboard that works in game until you press FLY, and I have tried multiple keyboards (too much spare PC junk at home), have removed the wireless dongle for the Xbox control pad in case that interferes, race peddles been unplugged, Snowball mic unplugged (this seemed to help the game load for some reason), webcam is unplugged. I just have the Warthog HOTAS and Stream Deck plugged in now (which I see other users using online with no problems so I know that its OK).

Reproduction steps are easy, boot game, press FLY, no keyboard appearing in the list of controllers and the keys not working. Even wondering about plugging in a couple of Thrustmaster Cougars and mapping the keys to that but that’ll take ages and really not fix the problem.

Thanks for showing an interest, at least you appear to have read what I wrote rather than the Support Ticket responder who appears to have just wanted to close a nearly two week old ticket. I really don’t mean to rant

I am unable to reproduce this error, which makes me wonder if there is some sort of issue to do with your hardware. I’m not at all suggesting it is your fault or your PCs fault, but there may be some quirk here that you are unfortunate enough to have stumbled into.

Did you send in a Dxdiag with any of your support tickets?

Don’t worry about it :slight_smile:

Just added one.

1 Like

And yes, it’s probably some obscure issue/conflict between something/somewhere.

If someone could tell me what the actual issue is I would just replace that part if needed, but I’m not going to just start replacing random PC parts yet as it’ll get expensive very quickly.

1 Like

Of course not. Hopefully, the dxdiag will help them trace the issue more effectively.

Sorry I cannot offer you a magic workaround in the meantime.

OK we have a SOLVED here, and you will not believe how bloody simple it turned out to be.

So when the game first loads and you look at the available controls it lists mine as Keyboard, Mouse, Joystick-HOTAS Warthog and Throttle-HOTAS Warthog. Under the HOTAS it says ‘Joystick/Throttle - HOTAS Warthog Profile’, Under Mouse is says ‘Default’ and under Keyboard it says ‘Keyboard Profile’.

I notice that the ‘Keyboard Profile’ has little arrows on each side implying that there are other profiles available, so I click them. The option underneath then changes to ‘Default’ and a whole bunch of keyboard assigned keys are listed.

Hell no, it can’t be that easy … but it is, I now have a working keyboard when I take off, so I can press Escape and things like the ATC commands all work now without needing to use the mouse.

So that was it, just one mouse click and I can now play the game/sim after a month of having it installed and cursing the bloody thing. OK it’s still very slow to start up, and it seems a 70/30 chance the program will even load, but it works.

Please feed this back to the other support staff, it might help some other player fix such a simple but serious problem.

Thanks for trying.

PS - this site has some strange word filters, lets me use ‘bloody’ but not ■■■■■■■. Or even d a r n which I would have thought was as mild as it gets.

1 Like

my keyboard controls are also not working

I had a same problem. No keyboard command at all. I try to select default, still no any active keyboard. A few days ago everything working well. At last I try to remove every controller, and I got back the default keyboards. I am saved it to a named profile quickly.
The problem was, I built a custom made controller with joystick and keyboard emulation. And the FS2020 does not ready to manage TWO keyboard!