Landing Challenge Cessna 208 B Grand Caravan Has no throttle control

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

2 tags are required: One for platform, and one for aircraft.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

All Mods have been disabled, Community folder is empty.

Which aircraft are you reporting an issue about? (Please also add the proper tag for it)

Cessna 208B Caravan

Brief description of the issue:

When flying LUKLA landing challenge, the plane starts with no throttle response. I have been able to get it started, but usually it’s too late and I crash. When in cockpit mode, there is no visual of a throttle control shown. The other landing challenges using this plane exhibit same no throttle response. If I start a flight with this plane, I have throttle response, but still no visual in cockpit of an actual throttle. I have uninstalled and reinstalled the package for this plane with no change. I also uninstalled the LUKLA challenge and reinstalled it.

Provide Screenshot(s)/video(s) of the issue encountered:

Picture of where throttle should be:

Picture showing no throttle response with joystick set to 3/4.

Detailed steps to reproduce the issue encountered:

Fly Lukla landing challenge.

PC specs and/or peripheral set up if relevant:
AMD Ryzen 5 3600 Nvidia 3080Ti Logitech Extreme 3D Pro

Build Version # when you first started experiencing this issue:

Don’t know, but I had flown LUKLA challenge previously without issues.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, can’t do any of the landing challenges with the Caravan. Was trying the spotlight events.

Provide extra information to complete the original description of the issue:

I’m playing on Xbox series X

If relevant, provide additional screenshots/video:

2 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

No

Provide extra information to complete the original description of the issue:

When I started the Lukla landing challenge, the throttle was part way up and jumped to flight idle as soon as I moved it slightly, but a quick push to full throttle and back made it work correctly for me.
I also noted in the OP’s screenshot, the prop control visual was missing. Mine was visual from the start of flight.
NOTE: This test was run in the BETA version 1.34.12.0
MS store version/pc/ no mods or add-ons, with TM Warthog throttle/joystick.
Regards

If relevant, provide additional screenshots/video:

1 Like

Tried this for the first time just now (pretty easy). First thing I did was look down (too busy to get a screenshot - sorry) and noticed the prop lever was missing. As soon as I touched the throttle on my X52, that lever popped in at the full fine position. I also noticed the condition lever was at ground idle. I have the two rotaries set for prop and mix/condition, so a quick blip of the condition rotary put the red lever full-forward. After that, it was just drop the flaps, find the runway, and plant the plane in the blue square.

Try not just emptying your Community folder. Start the sim, pull up the Task Manager (Ctrl+Shift+Esc), and use that to shut down the program. When you restart, the sim will think it crashed and give you the opportunity to start in Safe Mode. That will not only disable the Community folder, but any Official addons as well. Start a normal flight with the Caravan and verify that everything works there.

Same on my side in the landing challenges with the Cessna 208 B Grand Caravan EX

Same problem here with the caravan, but also the TBM at Courcheval

1 Like

Solution for throttle problems in landing challenges. I discovered that by pressing CTRL + ENTER gets the throttle working again on the Grand Caravan and Daher TBM in landing challenges. I read somewhere that CRL + ENTER is a shortcut to get the engine started, so it seems that although I am using a Thrustmaster stick and throttle on a PC, the engines need this keyboard input to wake up on these aircraft in landing challeges. This needs a software engineer type fix to get landing challenges working properly with these aircraft.

1 Like

Ctrl+E is the default engine start, but as long as it works…

1 Like

Agree, it is a workaround, but the frustrating thing is that it all worked normally until the last update, so there is still an obvious problem somewhere.

1 Like

This issue is also present in toranto landing challenge with the Daher TBM 930

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Though the throttle indicator increases through keyboard or Logitech Extreme 3D Pro, the engine remains idle. Additionally, there is no engine sound. Pressing Ctrl+E or just ‘E’ does not do anything.
Seeing the same issue in Toronto landing challenge. The engine appears to start revving (deviation of 3-4 degrees) but keeps going down. Although reverser (F2) key works fine and responds as expected.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

YES , landing challenge no throttle. No problem with throttle if I choose this plane out of “landing challenges” actitivities.

Provide extra information to complete the original description of the issue:

HOTAS Logitech X-52 . It´s not possible to activate engine of the Cessna Grand Caravan

If relevant, provide additional screenshots/video:

1 Like

Glad to see this has been tagged as bug logged. Looking forward to a fix in the future.
Regards

1 Like

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes

Brief description of the issue:

Using the Caravan (which works perfectly when I’m not in “Landing Activities”), there is no way to add power from either my external controls, keyboard or even sliding the throttle with mouse.

Provide Screenshot(s)/video(s) of the issue encountered:

None

Detailed steps to reproduce the issue encountered:

When starting the landing at Chagual or Sirena Station, the Caravan does not gain power through Extreme 3D Pro, my yoke/quadrant, my keyboard or by mouse (dragging the throttle). I’m not sure if there are other landings or aircraft involved but I did perform other successful operations with other locations and aircraft. Inevitably, the aircraft with no power, stalls and crashes.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

Not sure but I have the latest download and it occurred right after 13 was installed.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Exactly the same problem for me. Any of the turbo-prop engined aircraft in the landing challenges I have to press Ctrl-E immediately on loading or the challenge is impossible. It starts the challenge with the engine not responding. Like a lot of posters here I have a saitek throttle…. Not sure if that is part of the issue?

2 Likes

yes, same problem with the daher in the toronto landing-challenge

1 Like

Sorry, I am just read all the same issues I have with my X-52 and still no way to start the engine in the Caravan-Lukla landing challenge. I tried all …!!! please please help. I must land this at Lukla

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

No throttle control on TBM or Caravan other turboprop aircraft on Landing Challenges. Throttles work in other non-landing-challenge flying. This began occuring as of the last update.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes, except for the throttle lever (it is there and functionning normaly)

Provide extra information to complete the original description of the issue:

every landing challenge involving a turboprop starts with engine shutting down (spooling donw sound)

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

What to contribute: No matter what we do, it’s not working.
Textron Aviation Cessna 208 B is having throttle problem.
And it seems there no fixing.
Forget the activities with Textron Aviation Cessna 208 B!!!

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: