Last update broke visual experience in VR

high end PC VR user ( all up to date )

the last msfs update of a few kb destroyed completely the visuals . Its now only a shimmery blurry mess.

i reset 3 times the settings … its even worse with nis scaler on .

fps are ok 45 minimum .

i took Berlin like reference…

all settings to hight /ultra

even settings maxed out it looks AWFULLY…

i7/9gen overclocked
32 gb at 3200mhz
ssd samsung evo +
Meta Quest 2 cabled

That was only nav data, so it shouldn’t have affected anything to cause that.

my visuals was perfect before the little update… PERFECT

No doubt, but nav data won’t affect your visuals.
Coincidence maybe, but it wasn’t that update that caused it.
If you use the rolling cache, have you tried deleting it?

i dont use rolling cache . Several members of our group are experiencing the issues like me . So it isn’t a coincidence .

Server issue?
You definitely seem to have problems, but again a simple nav data text file change that has nothing to do with your settings cannot affect visuals.

iv have 1000 mb fiber
European server with low ping …
no … isn’t the server

server issues dont cause shimmering .

1 Like

Yeah, it’s hard to tell what folks mean by shimmering when we can’t see what you do.
It surprises me that your group sees it, which is why I thought server, it is one of the few things in common with a group.

this is my blurry mess after the last mini update …

before it was brilliant ,clear and good performance … now? i get still 45 fps , but there is no way to get rid the blurry mess …

Did the update change you settings?

No .

my settings are most at ultra…
but there is really no difference if i set it lower . only on the fps . 60+ fps in VR with High settings , 45 ± fps with ultra.

and both look awfully.

my rig is VR optimized . I run EVERY other game in ultra , good looking , a lot of FPS , no shimmering ore what else .
but msfs looks now like a blurry sh… now .
i spend THOUSANDS of euros in my rig…

but every msfs update is a bloody nightmare .

just dont make the updates mandatory, it doesn’t work for all user.

1 Like

I’m having a similar problem. No visuals in vr. I’ve tried everything I could think of. Did openXR again to make sure. Everything worked fine before update.

That looks like a really low resolution or something is compressing it to hell and back?

I don’t have a Quest 2, but is there a way to check what render resolution you are running or the compression/bandwidth it is using? (Like the ‘Devices / Graphics Preferences’ page of your Oculus app or Air Link bit rate etc)

I know the Quickstart | OpenXR Toolkit ( can show some of this info, so if you use that then maybe it’ll show what’s changed in the output?

I use a G2/WMR and no issues with last update, but you have my sympathy that it is really frustrating when VR goes wrong like that. :slightly_frowning_face: