Leaving the PC while on autopilot

I have tried three times to activate the autopilot (TBM and G36) and leave my PC for a while, and all three have ended in “tears”. Screensaver comes on and I find my plane belly up on the ground. First off. Why does the screensaver come on when the sim is in focus, and second, can I not leave my PC while flying for extended periods between waypoints.

Yesterday I had 45 minutes to the next waypoint and I had to walk our dog. I don’t have time in the day to do both so I thought the autopilot on ALT and NAV mode could handle a straight shot at 4000 ft. But no.

1 Like

To me, this sounds like a power saving setting within windows.
Try to disable the screensaver timer and look what happens.

Happy :small_airplane:

2 Likes

Burn in isn’t an issue on modern monitors. Just turn the screensaver off. As far as the AP killing you i’m not sure what could cause thst.

sounds obvious, but before I knew anything about anything, I’d forget that there are plenty of ways that the flight could run into issues…even simple things like remembering to turn on pitot heat…I had a few crashes where I’d left it running and didn’t do that.

Also, are you 100% sure that any of your usb devices are not having connection issues?

If you do ever get time to leave it running but still be nearby, you can then tell easily if any of your controls or panels have stopped responding. I’ve only recently (hopefully) solved this issue by switching everything to usb 2.0 ports hubs and cables. I had quite a few crashes too where I left it, something would freeze up or stop responding and it’s like the sim then stops recognizing the inputs and will set them to something else, e.g. it might set the throttle to zero, or put the trim all the way nose up causing a stall.

There’s loads that can go wrong, but unfortunately it’s hard to diagnose if you’re not watching lol.

If you have an AP panel that’s cutting out, the sim might be turning off the AP all together even?

::EDIT::

agree with other though, turn off the srceensaver…UNLESS you are using an OLED monitor, as these are still prone to burn in with static images left on the screen over time (although many OLEDs do have tech to attempt to counter this too)

Your screensaver shouldn’t turn the AP off, but given that’s what seems to be happening, just turn your screensaver off.

If your display being left on is a concern for you, turn your monitor off while you go walkies, and see if the same thing happens.

2 Likes

I would agree. No external factors, save the computer actually going to sleep, should affect the autopilot. It’s far more likely that something is wrong with the autopilot, or what it is being commanded to do is the issue. Like holding an altitude, and flying straight into terrain or structure.

@GeirRosset How was the AP programmed?

Since you said the plane to be belly up on the ground, that sounds to me like stalling. Neither those APs control airspeed, so are you sure you have sufficient throttle (and not too much on the TBM), enough fuel, or selected feeding from both tanks? And have you already arrived at your final waypoint so the AP disconnects?

1 Like

The AP disconnects if you pass the final waypoint? I am not sure. But I believe the plane went down about 5nm before my final waypoint.

Very certain I had enough throttle.

Fuel feed is something I need to check. The last time it happened there was more in one tank than the other…

Nah, it should just continue to circle indefinitely until you run out of fuel. (Assuming you don’t have unlimited fuel on)

You can use the active pause up in the top menu.This pauses the flight.

Actually no, it will go into SUSP on the Garmin and continue on current heading, speed and altitude.

1 Like

I don’t want to pause the flight. I want to leave it flying while I walk the dog so I can finish jobs in OnAir. If I’m not using OnAir, sure. Taking off and landing is most of the fun. The flight in between, not so much. But I don’t have enough time in a day to sit there and wait just looking “out the windows”…

Don’t use Active Pause, it will mess up your throttle settings on unpause, as well as act like it accumulated all the energy and height changes that affected the aircraft while paused and jar it badly.

Use Set Pause On and Set Pause Off - requires two separate keys or control buttons but well worth it.

2 Likes

In dev mode i think there’s a way to teleport? Can’t remember. This way you could take off, land and then walk the dog. There are also various landing challenges built into the sim.

If you have any of the logitech fip and spad.next there are also gauges available on fipgauges.com which do this for you and have lots of takeoffs and approaches to choose from.

Never used OnAir, but I’m guessing that kind of “cheating” would be detected by the client.

Can’t teleport. Or change the time in any way.

1 Like

Go look outside while in active pause… Is, the plane moving or is, it suspended in mid air?

It is an issue on OLED monitors.

It’s paused in position. But it’s also subject to changes over time - the oddball throttle settings are just one of them. Hit ESC while flying for a while, walk away for a bit, come back. Your throttle will not be where you left it. Set Pause ON, it will be.

I leave frequently during long flights with a dog, 2 year old and partner at home (add on top of that work obligations).

Took me a bit and of course plane dependent, but things to watch out for:

Check your power saving mode. At least in windows 11 there are two settings - screen saver (which doesn’t put computer in sleep mode) and the power savings “sleep mode”. Make sure the latter is turned off.

Speed is usually what kills me if my plane doesn’t have a managed speed mode. Either have to get the speed right so you won’t have any inadvertent over-speed or stall issues, or only fly managed speed and/or auto throttle planes.

Be back at your computer before approach mode kicks in if your avionics auto detects LOC.

Plane dependent, but could turn down turbulence settings, which in very rare occasions can trip up an AP in certain planes.

Make sure no hard turns upcoming as they can trip up your AP. I always check the route and do a back of the envelope calculation on how long you can be away before the route gets sketchy.

Just takes some trial and error.

1 Like