Limited by Main Thread: From 28 to 20 Frames

Hi Guys

My system: 5600x, 32 GB Ram, GTX 1070, Oculus Rift S

When I’m in desktop mode, I am limited by my GPU (which is fair) around 28 frames. In VR with the headset sitting on the table its the same (28 FPS, I adjusted the settings) but when I put the headset on it drops to around 20 and its suddenly limited by main thread.
Screenshots are attached.

Is there a way to optimize this? Does anyone else have this?

I’ve followed various guides on optimizing VR.

Cheers!

With headset off:

With headset on:

Normal on desktop:

Is it the same if you’re sitting as still as you can, or mostly when moving?
It could be that the lowered FPS w/ headset on is because of the offscreen loading, which was severely worsened in SU5. That also causes added CPU usage (not GPU usage) and will make you more likely to be limited by MainThread.

WU6 (Sep 7) will add back a cache that should improve this if that is the reason (see under World).

In the meantime, reducing terrain LOD is probably the main thing you can do to get a higher framerate.

It stays low even when I don’t move. And there is no difference between moving my head and holding it still.

Playing around with a few options outside of MSFS i found that it helped a lot when I turned motion reprojection back on in OpenXR. That brought back most of the Frames.

I’ve got the same system as you, except for a 3080 and my Devmode looks exactly like yours.
Reducing lod’s to 50 to 70% and it all runs extremely smooth but say’s mainthread limited.
Can’t make it Gpu limited, no matter what I do.
5600x, 32gb ram, Rtx 3080 and Rift S.

Glass instruments are heavy on the CPU (mainthread) as well as all the AI objects like ground personnel, AI flights, etc. As you start to move those glass gauges start working harder. Compare with an aircraft that has only steam gauges to see if that makes a difference.

My optimization method is to turn down Terrain and Object Level of Detail all the way. Then tune the other graphics settings until you get maximum FPS. Then dial up the Terrain and Object LOD’s until you get a level of FPS you can live with.